I have created each chapter file (.tex) which starts with \chapter{chapter name} and then I am trying to include all the files in one final document to create one .pdf file. In pdf output I see all other chapters included except one. It doesn't even recognize it as a chapter. It is neither in \tableofcontents nor in main body. Here's my minimal code. Can someone help me? I also referred other similar questions but none of them helped.

\documentclass[12pt, a4paper, twoside]{report}
\usepackage[total={6in, 8in}, margin=1in]{geometry}

\include{Chapter 1}
\include{Chapter 2}

closed as off-topic by user31729, Stefan Pinnow, user36296, Maarten Dhondt, user13907 Aug 25 '16 at 10:01

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    What happens if you remove the space between Chapter and 1 etc.? Spaces in filenames is never a good idea! – user31729 Aug 25 '16 at 8:55
  • Ahhh yes, this is the only file having space in between. Thanks. I will try it. – Ruchi Aug 25 '16 at 8:58
  • Wow. That worked. Thank you very much Christian. You saved my day. Can I ask one simple question here? Regarding including bibliography in \tableofcontents in my case? – Ruchi Aug 25 '16 at 9:02
  • Well, you can give \usepackage[nottoc,notlof]{tocbibind} a try. If you prefer to have the ToC and the LoF in your ToC as well, remove the nottoc and notlof options, however. But ... this is another question :-P – user31729 Aug 25 '16 at 9:04
  • 4
    I'm voting to close this question as off-topic because the issue(s) could be solved in comments – user31729 Aug 25 '16 at 9:12

Browse other questions tagged or ask your own question.