6

after the upgrade to Ubuntu 16.04. I have a problem with my Texstudio. I used to compile with the shortcut F6, but after the upgrade it doesn't work anymore (shortcuts in other programs are doing fine).

Thanks in advance, Luca

1
  • Can you try if you can set it manually? preferences->Shortcuts->Tools->Compile? Double click on the entry in the "Current shortcut" column Aug 26, 2016 at 16:52

5 Answers 5

1

This seems to be a known (and unfortunately, by now, rather long-standing) issue involving Qt5 (version 5 of Qt, the graphical toolkit used to create TeXStudio’s user interface). It has come up several times in TeXStudio’s bug tracker and other places; for example:

The solution is to install a version of TeXStudio that is built against the previous version, Qt4. Unfortunately, such a version is not available in Ubuntu’s default repositories. Instead, you can go to TeXStudio’s official download page and choose a link that says “QT 4”.

13

I found this solution here, it works fine for TeXStudio: Edit the file

/usr/share/applications/texstudio.desktop

and change the line

Exec=texstudio %F

to

Exec=env UBUNTU_MENUPROXY= texstudio %F

NOTE: Remember to edit the file again after upgrade to version 2.12.2, released Jan 24, 2017.

NOTE (Jul 25, 2017): TeXStudio released yesterday: TeXstudio 2.12.6 (hg 6631:16db084dae24). Using Qt Version 5.5.1, compiled with Qt 5.5.1 R, works fine without any edit of file /usr/share/applications/texstudio.desktop. The nightmare is over!!!

5
  • 1
    It works as a charm!
    – user296113
    Jan 21, 2017 at 13:26
  • 2
    Worked for me on Ubuntu 16.04.
    – Roald
    Jan 26, 2017 at 12:51
  • any chance of doing this without sudo access?
    – E.P.
    Jan 31, 2017 at 17:26
  • @E.P., the superuser root is the owner of /usr directory, so you need her/his credentials in order to modify texstudio.desktop file.
    – tatojo
    Feb 10, 2017 at 15:24
  • 1
    @tatojo I found it later - this also works by copying that file to ~/.local/share/applications/ and modifying that copy.
    – E.P.
    Feb 10, 2017 at 15:36
4

This is bug in Qt-5 package. Remove the "appmenu-qt5" package to get the shortcuts working again.

                   sudo apt remove appmenu-qt5

This seems to induce some changes in the appearance of menu buttons in TexStudio, but the shortcuts are enabled.

1
  • 1
    This solution worked for me on Ubuntu 14.04.5 LTS 64-bit with qt5 compiled Texstudio.
    – Vesnog
    Jan 8, 2017 at 2:38
2

A different solution to what @Socob suggested might be (for Ubuntu 16.04) to navigate to the applications folder (/usr/share/applications) as sudo, right-click on 'texstudio' and select 'Properties'. Change the 'texstudio %F' to 'env UBUNTU_MENUPROXY= texstudio %F'. At least, that did it for me. I am not aware of any downsides to this.

EDIT: As pointed out by @Orion in the comment, the HUD stops working when using this solution. This has never been an inconvenience to me, since I never use the HUD, but as always, it's good to be aware of the possible downsides.

2
  • 1
    Worked for me 16.04 (TeXstudio 2.11.2 Using Qt Version 5.5.1, compiled with Qt 5.4.2 R). This seems to disable the Heads Up Display (HUD) for TexStudio menus.
    – Orion
    Dec 15, 2016 at 19:55
  • Good find @Orion I added this in an edit in the answer. Dec 21, 2016 at 10:36
0

One workaround (worked for me) is to add the menu command to the toolbar (from Configure/Toolbars), then the assigned keyboard shortcut could work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.