1

I am using the memoir document class, with chapters. However, I would like to remove the Chapter title from each, so it doesn't say "Chapter 1" and then "Introduction" underneath. I just want it to say "Introduction." Yet, when I remove Chapter titles by using * , I cannot call then in the Table of Contents. So, I am wondering how to change the Chapter titles, or if there is another way to solve this?

\documentclass[a4paper,oneside, 11pt, openany]{memoir}
\setcounter{secnumdepth}{2}
\tableofcontents

\mainmatter

\chapter{Introduction}
\input{chapters/intro}

\chapter{Methods}
\input{chapters/chapter02}
  • Add \setcounter{secnumdepth}{-1} to the preamble to have all chapters unnumbered. or have a look at that question from yesterday: Fixing Table of Contents in Memoir Class – Johannes_B Aug 29 '16 at 5:08
  • @Johannes_B memoir has an easier interface \setsecnumdepth{none} to turn of numbering completely. To the OP: why don't you want the introduction numbered if it is part of the mainmatter. If it just listing what you are doing in this doc, then also use \frontmatter and move the introduction up before \mainmatter . Btw: that secnumdepth you are doing is being reset by \mainmatter , look up \setsecnumdepth and \maxsecnumdepth in the memoir manual – daleif Aug 29 '16 at 5:35
  • @daleif Do you want to add an answer? – Johannes_B Jan 29 '17 at 13:44
1

In memoir frontmatter disables sec numbering. \mainmatter re-enable it, but frontmatter does not store the current value and restores it. Rather is restores to a user defined value.

So in memoir the proper method is:

\setsecnumdepth{subsubsection} 
\setmaxsecnumdepth{subsubsection} % mainmatter restore to this 

There is a similar command (\settocdepth) to set the depth of the toc. Its max version is hardly ever needed (I've never used it)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.