0

Impossible to automatically generate BibTex keys using Ctrl-G as I did it with the previous version of JabRef. It seems that there is a bug in this issue of Jabref. Please help me...

closed as off-topic by Joseph Wright Sep 1 '16 at 13:12

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Did you tried the magic wand ? Sorry, I am still using version 2.10 which comes with my distribution so I won't help much. – DRi Aug 30 '16 at 9:10
  • The same thing occurs with the magic wand – Jean-François Ponge Aug 30 '16 at 9:19
  • 2
    Bug reports are normally off-topic here. You'll want to notify the authors directly (github.com/JabRef/jabref/issues). On top of that your question lacks a few details that you should probably include in a bug report. What exactly are you trying to do, what did you expect, what happens instead? – moewe Aug 30 '16 at 9:22
  • What the OP wants is clear, it is to automatically generate a Bibtex key (say from the Author an Year fields) in JabRef. The shortcut has maybe changed or your installation is not complete (I cannot imagine that the function has disappeared in this last version). However it may not be relevant to (La)TeX since it has more to do with the internals of JabRef. – DRi Aug 30 '16 at 10:20
  • Just a note: The JabRef hotkey system is under rework at the moment, as it has been very inconsistent so far, see, e.g., this. Your issue is probably related to that. – joergl Sep 1 '16 at 9:23
1

I found a solution to this problem, by selecting (in Tools then Preferences) the automatic generation of BibTex keys when they are empty. This allows JabRef to fill them in the common way (Nameyear).

Not the answer you're looking for? Browse other questions tagged or ask your own question.