1

I'm getting misleading warning of the missing character "q" in a place where I actually see it printed. The output is fine. Problem is in \widehat{\boldsymbol{\mathfrak{q}}}. I know that dsrom10 font has only capital letters (and few more symbols), but tex should not take it at all in \widehat. Egregs solution dsrom skewchar doesn't help. From tracing it seems something wrong with \boldsymbol font selection. Probably \bm@mchoice takes the latest registered math version normal which is \mathds.

MWE:

\documentclass{article}
\usepackage{amssymb}
\usepackage{bm}
\usepackage{dsfont}
\begin{document}
$\mathds{A}$
$\boldsymbol{\mathfrak{q}}$
$\widehat{\boldsymbol{\mathfrak{q}}} $
\end{document}

Warnings:

Missing character: There is no q (U+0071) in font dsrom10!
Missing character: There is no q (U+0071) in font dsrom10!
Missing character: There is no q (U+0071) in font dsrom8!
Missing character: There is no q (U+0071) in font dsrom8!

Could somebody point me to a global solution. (Re-typesetting the document is not the option).

  • 1
    Those warnings are innocuous. – egreg Aug 30 '16 at 10:22
  • I don't get these warnings. The information is printed to the .log but they are not marked as warnings. – cfr Aug 30 '16 at 10:29
  • 1
    I wouldn't say that. Some times it's really missing glyphs. – Linuxss Aug 30 '16 at 10:29
  • it seems that if you enter the last line as $\boldsymbol{\widehat{\mathfrak{q}}} $ the warning doesn't appear. but i can't explain why. – barbara beeton Aug 30 '16 at 13:44
  • Barbara, that example is tricky. I waste a lot of time shorting it to minimal from the article. – Linuxss Aug 31 '16 at 5:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.