0

I'm trying to format a bibliography in a tufte-book document in Chicago Author-Date style. There are no citations in the document itself. Can anyone help? Here is the syntax:

\begin{document}

\maketitle

\tableofcontents

\input{tex/0_theground}
\input{tex/goldstein}
\input{tex/patterson}
\input{tex/barrett}

\usepackage[authordate,backend=biber,bookpages=false,doi=false,isbn=false,url=false]{biblatex-chicago}
\bibliography{bib/test}
\nocite{*}

\end{document}
4
  • A tip: If you indent lines by 4 spaces, they'll be marked as a code sample. You can also highlight the code and click the "code" button (with "{}" on it).
    – DG'
    Commented Aug 31, 2016 at 10:34
  • 1
    Also: Please make your code compilable (if possible), or at least complete it with \documentclass{...}. That may seem tedious to you, but think of the extra work it represents for TeX.SX users willing to give you a hand. Help them help you: remove that one hurdle between you and a solution to your problem.
    – DG'
    Commented Aug 31, 2016 at 10:35
  • Sure thing: pastebin.com/hPHEPkU8 Commented Aug 31, 2016 at 11:24
  • 1
    Please consider adding the full MWE here instead of on pastebin. You might also want to read up on what makes a good MWE.
    – moewe
    Commented Aug 31, 2016 at 12:01

1 Answer 1

1

You should use \addbibresource (you need to include the file extension .bib) instead of \bibliography, and you have to print the bibliography with \printbibliography.

Also, you need to call tufte-book with the class option nobibin order to make biblatex work.

The result should look like this:

\documentclass[nobib]{tufte-book}
\usepackage[authordate,
            backend=biber,          % You need to run biber instead of bibtex
            bookpages=false,
            doi=false,
            isbn=false,
            url=false]{biblatex-chicago}

\addbibresource{bibliography.bib}   % You need to include the file extension, e.g. ".bib"

\begin{document}
    Test

    \nocite{*}
    \printbibliography
\end{document}
7
  • Odd, now the bibliography has vanished completely pastebin.com/9uCbXthp Commented Aug 31, 2016 at 11:38
  • @christopher You'll need to run Biber on your file, see Question mark or bold citation key instead of citation number and Biblatex with Biber: Configuring my editor to avoid undefined citations
    – moewe
    Commented Aug 31, 2016 at 12:00
  • @christopher I also notice that you wrote \addbibresource{bib/test}. You need to include the file extension (.bib) (this is exactly contrary to what you do in \bibliography - there you leave out the extension .bib), so it would probably be \addbibresource{bib/test.bib}. Make sure that Biber is allowed to access the folder bib or put the file into the same directory as your main file.
    – moewe
    Commented Aug 31, 2016 at 12:16
  • Thanks @moewe. When I try to compile the test that DG proposed: \documentclass[nobib]{tufte-book} %\usepackage{fontspec} \usepackage[authordate,backend=biber]{biblatex-chicago} \addbibresource{test.bib} \begin{document} Test \nocite{*} \bibliography \end{document} I get these errors from bibtest.blg: I found no \citation commands---while reading file bibtest.aux I found no \bibdata command---while reading file bibtest.aux I found no \bibstyle command---while reading file bibtest.aux Commented Aug 31, 2016 at 12:36
  • 1
    @christopher Use \printbibliography[heading=bibintoc]. The page number is always missing on the very first page of a chapter. If you don't want that have a look here.
    – moewe
    Commented Aug 31, 2016 at 14:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .