If I compile a TikZpicture with a Stealth arrow in LyX I receive some errors of this kind:

Missing character: There is no ... in font nullfont!

(which are considered only informational in TeXstudio).

Searching for the reason of the problem, I've added the code line suggested here by David Carisle and some strange "ptptptptptptpt" appear, but I can't understand where these chars come from.

enter image description here

The problem can be easily worked around with externalization but, since I'm becoming addicted to TEX.SE, I'd like to know if my code has an error.


% just for showing the error

% tikz
\usetikzlibrary{calc, intersections}


    axis lines=middle,
    no markers, 
    xmin=-4, xmax=7, ymin=0, ymax=4,

\node (coda) at (axis cs: 3, 2) {Why this?}; 
\node (punta) at (axis cs: 1, 1) {}; 

\draw [-{Stealth[scale=0.7]}] (coda) -- (punta);




I'm using LyX 2.2.1 and TeXstudio 2.11.0 with MiKTeX 2.9 distribution.

As requested by egreg, here is the file list:

 *File List*
    book.cls    2014/09/29 v1.4h Standard LaTeX document class
    bk10.clo    2014/09/29 v1.4h Standard LaTeX file (size option)
inputenc.sty    2015/03/17 v1.2c Input encoding file
    utf8.def    2016/02/28 v1.1s UTF-8 support for inputenc
   t1enc.dfu    2016/02/28 v1.1s UTF-8 support for inputenc
  ot1enc.dfu    2016/02/28 v1.1s UTF-8 support for inputenc
  omsenc.dfu    2016/02/28 v1.1s UTF-8 support for inputenc
   babel.sty    2016/04/23 3.9r The Babel package
 bblopts.cfg    2005/09/08 v0.1 add Arabic and Farsi to "declared" options of b
 english.ldf    2012/08/20 v3.3p English support from the babel system
    tikz.sty    2013/12/13 v3.0.0 (rcs-revision 1.142)
     pgf.sty    2013/12/18 v3.0.0 (rcs-revision 1.14)
  pgfrcs.sty    2013/12/20 v3.0.0 (rcs-revision 1.28)
everyshi.sty    2001/05/15 v3.00 EveryShipout Package (MS)
 pgfcore.sty    2010/04/11 v3.0.0 (rcs-revision 1.7)
graphicx.sty    2014/10/28 v1.0g Enhanced LaTeX Graphics (DPC,SPQR)
  keyval.sty    2014/10/28 v1.15 key=value parser (DPC)
graphics.sty    2016/07/10 v1.0t Standard LaTeX Graphics (DPC,SPQR)
    trig.sty    2016/01/03 v1.10 sin cos tan (DPC)
graphics.cfg    2016/06/04 v1.11 sample graphics configuration
  pdftex.def    2016/07/10 v0.06j Graphics/color for pdfTeX
infwarerr.sty    2016/05/16 v1.4 Providing info/warning/error messages (HO)
 ltxcmds.sty    2016/05/16 v1.23 LaTeX kernel commands for general use (HO)
  pgfsys.sty    2013/11/30 v3.0.0 (rcs-revision 1.47)
pgfsyssoftpath.code.tex    2013/09/09  (rcs-revision 1.9)
pgfsysprotocol.code.tex    2006/10/16  (rcs-revision 1.4)
  xcolor.sty    2016/05/11 v2.12 LaTeX color extensions (UK)
   color.cfg    2016/01/02 v1.6 sample color configuration
pgfcomp-version-0-65.sty    2007/07/03 v3.0.0 (rcs-revision 1.7)
pgfcomp-version-1-18.sty    2007/07/23 v3.0.0 (rcs-revision 1.1)
  pgffor.sty    2013/12/13 v3.0.0 (rcs-revision 1.25)
pgfplots.sty    2016/08/10 v1.14 Data Visualization (1.14)
pdftexcmds.sty    2016/05/21 v0.22 Utility functions of pdfTeX for LuaTeX (HO)
ifluatex.sty    2016/05/16 v1.4 Provides the ifluatex switch (HO)
   ifpdf.sty    2016/05/14 v3.1 Provides the ifpdf switch
epstopdf-base.sty    2016/05/15 v2.6 Base part for package epstopdf
  grfext.sty    2016/05/16 v1.2 Manage graphics extensions (HO)
kvdefinekeys.sty    2016/05/16 v1.4 Define keys (HO)
kvoptions.sty    2016/05/16 v3.12 Key value format for package options (HO)
kvsetkeys.sty    2016/05/16 v1.17 Key value parser (HO)
etexcmds.sty    2016/05/16 v1.6 Avoid name clashes with e-TeX commands (HO)
  • 1
    I can't reproduce this can you update your MikTeX ? Or it is a LyX issue.
    – percusse
    Sep 2 '16 at 6:57
  • @percusse Of course you have to comment the line \font\nullfont=cmr10 to see them. I've already updated MikTeX. LyX shows the first error in a pop-up, TeXstudio doesn't highlight these messages as errors or warnings but they are present in the log. Thank you!
    – CarLaTeX
    Sep 2 '16 at 7:05
  • with or without comment I don't see them. Though there is some whitespace leaking
    – percusse
    Sep 2 '16 at 7:33
  • 2
    ”Missing character“ is only a warning and in the case of TikZ it is often issued by design, because the current font is set to \nullfont in order to avoid spurious typesetting. If LyX makes those warnings into errors, you have two choices: either trying to see if this behavior can be turned off or giving up with LyX. The latter is the choice I recommend.
    – egreg
    Sep 2 '16 at 7:48
  • 1
    The only difference I see is that you have TikZ/PGF version 3.0.0 instead of 3.0.1a; in my TeX Live 2014 I indeed have version 3.0.0 and the spurious characters appear.
    – egreg
    Sep 2 '16 at 8:18

The warning about Missing character p in \nullfont only appears if you use TikZ/PGF version 3.0.0 (previous versions don't have the arrows.meta library), but not if you use the current version 3.0.1a.

On the other hand, the warning has no consequence on the picture, so you could as well ignore it (but upgrading is recommended).

Avoiding LyX turning such warnings into errors is off-topic here, because it cannot be fixed on the TeX side, unless there's some preference to set.

Update your TikZ/PGF version.

  • I've managed to install the new version, on the MiKTeX package manager I see the 3.0.1a version installed on 2016-09-02 but when I run the code with \listfiles I still see pgf.sty 2013/12/18 v3.0.0 (rcs-revision 1.14): how can this be possible? What trouble do I get into?
    – CarLaTeX
    Sep 2 '16 at 14:25
  • @CarLaTeX You probably incurred in a double installation of MiKTeX (Administrator and User).
    – egreg
    Sep 2 '16 at 14:27
  • In fact under MiKTeX I see Update and Update (Admin), the same for Package Manager and Settings, but I've always used the Admin version (at least I thought that). Should I disinstall and reinstall MiKTeX? Is it dangerous?
    – CarLaTeX
    Sep 2 '16 at 14:37
  • @CarLaTeX I know almost nothing about MiKTeX for lack of hardware/software supporting it. On Windows it's very common to uninstall and reinstall software, as far as I know.
    – egreg
    Sep 2 '16 at 14:39
  • I uninstalled MiKTeX, reinstalled for my user only and now all works perfectly well: tikz.sty 2015/08/07 v3.0.1a (rcs-revision 1.151) pgf.sty 2015/08/07 v3.0.1a (rcs-revision 1.15) and the strange chars are disappeared. Thank you again!
    – CarLaTeX
    Sep 3 '16 at 6:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.