3

Yesterday (Sep. 1, 2016) I ran all of the automatic updates for my MiKTeX. Since then, my TeXworks has not been writing .log or .aux files, at least not in the same directory as my .tex file or anywhere that I can think to look. Naturally this a problem since I search these files for warnings, missing character messages, multiply-defined labels, etc. Is there anything I can do to try to fix this problem? I'm using TeXworks Version 0.6.1 (MiKTeX 2.9) [r.3614278, 5/1/2016 4:43 AM], and my computer is Windows 7.

Even a file as simple as

\documentclass{article}
\begin{document}
\section{Test}\label{sec1}
Reference to section \ref{sec1}.
Reference to section \ref{sec2}.
\end{document}

produces, in its directory, only a .pdf file and a .synctex.gz file. Oddly, the \ref{sec1} command prints correctly as "1". The \ref{sec2} command prints as "??", obviously, but since I have no .log file I have no way of confirming that the paper has undefined references.

EDIT: I'm also set up to run normal LaTeX on a .tex file via DVIWindo, and DVIWindo seems to have "seen" all the appropriate MiKTeX updates I made; the updated files are being used, and the .aux and .log files are still being written as normal.

  • After using TeXworks with pleasure for several years, there were minor bugs that made me switch to TeXstudio eventually. – JPi Sep 2 '16 at 12:27
  • Have you tried running a search over your whole computer for *.log and sorting by date to see if it's putting them somewhere wierd? If the compilation is slow (and a deliberate \hanghere should help with that unless you have scrollmode automatically set) leaving the search window open should show where it puts the log even if it's deleting it at the end of the run. – Chris H Sep 2 '16 at 14:31
  • 2
    Check the profile settings in texworks. Probably you have a --clean option somewhere. – Ulrike Fischer Sep 2 '16 at 14:42
  • @Ulrike Fischer: Thanks. Where should I look for the profile settings? – MSC Sep 2 '16 at 14:56
  • Somewhere in the texworks settings. – Ulrike Fischer Sep 2 '16 at 15:01
3

Okay, I just now (Sep. 9, 2016) followed the instructions in the answer to this question to find the "--clean" option and remove it. It was under pdfLaTeX+MakeIndex+BibTeX. Now my TeXworks is writing all the files it should. If this is enough, thanks for your help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.