1

The present question is the continuation of the previous discussion (See here).

I've tried to change BiBTeX style for needed purpose by two ways: using custom-bib and by modification of plainnat.bst file (thanks to Mico's suggestion). Both times I got the same result: enter image description here

That is, initials before points were lost. I'm sure, that the issue is caused by necessity to use specified options for precessing BiBTeX-file in Russian. Can anybody help me?

  • Please don't show us just a screenshot of the problematic output. What we really need to see, in order to be able to offer a diagnosis, is the code that gives rise to the problematic output. Please prepare a minimum working example, including a couple of bib entries. – Mico Sep 2 '16 at 20:40
  • OK. The code with problematic output can be downloaded from: here – Konstantin Sep 2 '16 at 21:07
1

I don't think the missing-characters business you're encountering is related to BibTeX, at least not directly. I downloaded the files you posted off-site and have had a look. I'm very sorry my Russian -- and even my ability to read text that uses Cyrillic letters -- isn't all that good. The following is therefore mainly going to be a set of suggestions, which you may want to treat as no more than a starting point for further investigations.

  • Since your files are utf8-encoded, I strongly recommend you use a TeX engine that's fully utf8-enabled. I suggest you use LuaLaTeX. (I assume you've been using pdfLaTeX so far. Is that correct?) If you choose this route, you should comment out (or simply delete) the instructions \usepackage[T2A]{fontenc} and \usepackage[utf8]{inputenc} from the preamble of the main tex file. In their place, (a) insert the instruction \usepackage{fontspec} and (b) choose a font (via a \setmainfont instruction) that's on your system and has excellent support for Cyrillic characters. On my system (MacOSX 10.11.6; MacTeX2016), I found "Garamond Premier Pro"; I thus wrote \setmainfont{Garamond Premier Pro} in the preamble. I trust you'll have several good fonts to choose from on your system.

  • Run LuaLaTeX once.

  • Next, instead of running "basic" BibTeX, which can probably handle only ASCII-encoded material without generating meaningless error messages, consider running bibtexu, which is utf8-enabled. You will probably need to open a command window, switch to the directory that contains your main tex file (SampleFile.tex, say), and type

    bibtexu SampleFile
    

    Ignore any cryptic error messages.

  • Then, run LuaLaTeX twice more to generate both the formatted bibliography and citation call-outs.

I get the following output from this exercise; is this roughly what it should look like?

enter image description here

\documentclass{article}
% I've shrunk your tex file down to the absolute minimum...
\usepackage{fontspec}
\setmainfont{Garamond Premier Pro} 
\usepackage[russian]{babel}
\usepackage[square,numbers,sort&compress]{natbib}
\bibliographystyle{plainnat-re}
\begin{document}
Citations: \citep{Ajn1962, AbrAru1963, Bab1984, AlbN1972}
\bibliography{sample_bib}
\end{document}
  • Thank you for suggestion. I use a dvi previewer for TeX compilation. As use of bibtexu is not recommended by the most of experts (I consulted at a number of sites), I apply the following workaround here. And it does work! In any case, I appreciate you for valuable tips. – Konstantin Sep 3 '16 at 6:51
  • @Konstantin - Glad my suggestion was at least somewhat useful, and glad you found the other posting, in which egreg suggested a work-around for cyrillic-alphabet initials. (You might end up doing a lot of recoding of first initials, though...) About bibtexu: its usability and stability appear to depend importantly on how many bytes are used to encode a given utf8 character. Cyrillic-alphabet characters are mostly (exclusively?) encoded using 2 bytes per character, and bibtexu seems to be fine with those. Finally, do feel free to upvote and/or accept my answers. ;-) – Mico Sep 3 '16 at 7:49
  • @Konstantin - About the use of a dvi previewer: I understand that's an issue that's separate from the engine and format used to compile the files. To create a dvi file rather than a pdf file with LuaLaTeX, type lualatex --output-format=dvi <tex-file> at a command line. Alternatively, configure your front-end so that the string --output-format=dvi when running LuaLaTeX. – Mico Sep 3 '16 at 7:55
  • Thank you. It is very simple to do so in my bundle MiKTeX+WinEdt. Regards – Konstantin Sep 3 '16 at 10:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.