0

I'm citing multiple chapters from the same edited volume. The bst style is ieeetr.

The current output is something like this (identifiers have been replaced with gibbrish):

[1] A. BCD, "Chapter 5 title" in Doe [3], ch. 5, pp. 10-14.

[2] E. FGH, "Chapter 6 title" in Doe [3], ch. 6, pp. 23-34.

[3] X. Y. Doe, ed., vol. 11. Z Publishing, 2015.

It seems that above a certain number of citations from the same volume the volume is referenced as a separate citation.

What I would like is to: 1) have the full volume details appear for each chapter citation, not in an abbreviated format like [3], and 2) remove the reference of the volume by itself.

Thanks

  • Welcome to TeX.SX! From the information that you have given it is difficult to determine what your problem is. Please edit your post to add a minimal working example, that begins with a \documentclas command, the packages that you use and then \begin{document}...\end{document}. You should also include your bibtex file entries for the three papers above because it is quite likely that the problem is in your bibtex file. – Andrew Sep 6 '16 at 7:19
1

This happens when

  • your BibTeX entry of the chapter has a crossref field, and
  • the cross-reference is cited (directly using \cite or indirectly using crossref) at least twice.

Consider the following MWE:

test.tex

\documentclass{article}

\begin{document}

\cite{ch}
\cite{book}

\bibliographystyle{ieeetr}
\bibliography{bib}

\end{document}

bib.bib

@inbook{ch,
  title={Chapter},
  crossref={book}
}

@book{book,
  title={Book title},
  editor={Doe, John}
}

It reproduces your observations. If you either remove the crossref or remove the \cite{book}, the nested citation disappears.

BibTeX resolves cross-references automatically when an item is used only once. For example, if you only \cite{ch}, then book is cited only once (indirectly by crossref), and thus its fields are automatically used by the chapter. If an item is used at least twice, it gets its own entry, and the cross reference is cited within the bibliography.

You can configure how oft a citation must be used before it gets its own entry by the BibTeX option -min-crossrefs=<N>. If you never want the cross-reference to be displayed, use a very large number, e.g. bibtex -min-crossrefs=<N>.

Related: Full citations of bibtex items despite crossref?

  • Many thanks. Is there a way to use crossref AND have the full book details in each citation? . – user51726 Sep 6 '16 at 8:52
  • No, not without hacking the bibtex styles (as far as I know). – Martin Nyolt Sep 6 '16 at 9:01
  • Thanks again. The "workaround" I've used was to define the @book entry multiple times ( @book{a:1,...} @book{a:2,...} ), and then each chapter entry used a different book reference. – user51726 Sep 6 '16 at 10:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.