1

I'm following this to learn a bit about pgfplots. I am trying to draw a boxplot following the example shown on page 469, but I get the I do not know the key '/pgfplots/boxplot lower whisker' error. The following is a minimal not working example. I tried to follow what has been said here but that did not solve the problem. I'm using pgfplots version 1.8.

Here is the example I'm trying to run:

\documentclass[11pt,a4paper,twoside,openright]{report}

\usepackage{pgfplots}
\usepgfplotslibrary{statistics}
\usetikzlibrary{pgfplots.statistics}

\begin{document}

\begin{tikzpicture}
    \begin{axis}
        \addplot+[
            boxplot prepared={
                lower whisker=1.8486258271519964,
                lower quartile=1.8572585927933791,
                median=1.8642658118607576,
                upper quartile=1.8672130149052513,
                upper whisker=1.8736136816889981,
            }
        ]
        table[row sep=\\,y index=0] {
            data\\ 1\\ 3\\
        };
    \end{axis}
\end{tikzpicture}

\end{document}
3
  • 1
    You need to update your TeX distro. Current version is 1.14
    – percusse
    Sep 7, 2016 at 18:00
  • Had some trouble updating the TeX distro, but that solved the issue! Thank you very much!
    – Masiar
    Sep 8, 2016 at 8:22
  • 5
    I'm voting to close this question as off-topic because it was solved by updating PGFPlots to v1.14. Sep 9, 2016 at 19:59

0

Browse other questions tagged .