2

I often have a lot of notes for a specific slide in Beamer. When I try to print them out, Beamer leaves some of the notes off because they don't fit on the slide. Changing the font size sometimes solves the problem, but that can make the text hard to read. Is there a way to have Beamer tell if all the notes will fit on a page and if they don't, make a new frame with the rest of the notes?

  • 1
    Welcome to TeX.SX! You can help us to help you by providing the LaTeX code for a small document that shows your problem. Just edit your question and add the code. – gernot Sep 7 '16 at 19:10
2

If you put [allowframebreaks] on the frame then beamer will automatically break the slide and change the title to Really Long Slide I, Really Long Slide II, etc. See example below and see it in action at the link

\documentclass{beamer}

\usepackage[english]{babel}
\usepackage[utf8x]{inputenc}
\usepackage{blindtext}

\begin{document}

\begin{frame}[allowframebreaks]{Really Long Slide}

\blindtext[5]

\end{frame}

\end{document}
  • But does this also work for the content of a \note{}? – user36296 Sep 7 '16 at 19:03
  • @samcarter If that is what the OP is asking then they should look at this answer – MathIsKey Sep 7 '16 at 19:14
  • That might indeed be a duplicate, at least as I understood the question. Let's wait for feedback from the OP. – user36296 Sep 7 '16 at 19:16
  • In my preamble, I have defined a command to create notes with bullets (\newcommand{\inote}[1]{\note{ $\bullet$ #1 \\ \vs}}). I use the \inote command within a frame. When I am ready to print out my notes, I use \setbeameroption{show only notes} in my preamble and then print out the PDF. Does that help? – AQFT Sep 9 '16 at 2:42
1

Are external note pages (not from within a frame) be an option?

\documentclass{beamer}

\setbeameroption{show notes}

\begin{document}

\begin{frame}
\frametitle{blub}
    abc
\end{frame} 

\note{text}
\note{more text}    

\end{document}
  • In my preamble, I have a command to make notes with bullets. \newcommand{\inote}[1]{\note{ $\bullet$ #1 \\ \vs}} and when I need to print out the notes I make this change in the preamble \setbeameroption{show only notes}. I then print out the PDF. I always use this inote command within a frame. Does that help? – AQFT Sep 9 '16 at 2:36
  • @AQFT If you use such non-standard setup, it would be good to have a minimal working example (MWE) in your question, that demonstrates you problem. – user36296 Sep 9 '16 at 10:51
  • Sorry for the delay, I was having trouble paring down my preamble. Clumsily, I have added notes until "10" does not fit on the frame. \documentclass{beamer} \mode<presentation> \usepackage{amsmath} \newcommand{\vs}{\vspace{10pt}} \newcommand{\inote}[1]{\note{ $\bullet$ #1 \\ \vs}} \setbeameroption{show notes} \begin{document} \begin{frame}[allowframebreaks] \inote{1} \inote{2} \inote{3} \inote{4} \inote{5} \inote{6} \inote{7} \inote{8} \inote{9} \inote{10} \end{frame} \end{document} – AQFT Sep 11 '16 at 14:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.