5

Let's assume we have a simple «hello world» in Japanese (/sue:den/ — that's Sweden in Japanese):

\documentclass{utarticle}
\begin{document}
スウェーデン。
\end{document}

The utarticle class tells the LaTeX to render it vertically, and so far it's just as expected. But here comes the issue (actually, even three of them):

  1. The long vowel sign (ー) in the vertical layout also must be vertical. But it isn't.
  2. The small «e» (エ) must be shifted to the right edge of the column. But it isn't.
  3. The full stop (。) must be also adjusted by the right edge of the column. But it isn't.

A picture of the real output vs. desired result: png

Platform — Linux, Fedora 24.

How to get it working? (solved)

 *File List*
 upldefs.ltx    2000/07/13 v1.2u01 upLaTeX Kernel (Default settings)
 jy2mc.fd    1997/01/24 v1.3 KANJI font defines
 jy2gt.fd    1997/01/24 v1.3 KANJI font defines
 jt2mc.fd    1997/01/24 v1.3 KANJI font defines
 jt2gt.fd    1997/01/24 v1.3 KANJI font defines
 ukinsoku.tex
 uplpatch.ltx
 utarticle.cls    2011/05/07 v1.6_u00 Standard upLaTeX class
 utsize10.clo    2011/05/07 v1.6_u00 Standard upLaTeX file (size option)
 plext.sty    
 ***********

Solution

Thanks to @JosephWright : do not use LaTeX provided by Fedora's packages, instead install the fresh LaTeX from the site.

png

After the upgrade:

 *File List*
 upldefs.ltx    2016/06/29 v1.6e-u00 upLaTeX Kernel (Default settings)
 jy2mc.fd    1997/01/24 v1.3 KANJI font defines
 jy2gt.fd    1997/01/24 v1.3 KANJI font defines
 jt2mc.fd    1997/01/24 v1.3 KANJI font defines
 jt2gt.fd    1997/01/24 v1.3 KANJI font defines
 ukinsoku.tex
 utarticle.cls    2011/05/07 v1.6-u00 Standard upLaTeX class
 utsize10.clo    2011/05/07 v1.6-u00 Standard upLaTeX file (size option)
 plext.sty    2016/08/20 v1.2a pLaTeX package file (community edition)
 ***********

closed as off-topic by egreg, Stefan Pinnow, Zarko, Przemysław Scherwentke, Torbjørn T. Sep 9 '16 at 22:00

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Could you add a screenshot of what you see to make it clear to others? – Joseph Wright Sep 9 '16 at 13:07
  • 1
    are you using the cjk-package, which provides support for Asian languages? see also: preining.info/blog/2014/12/… – naphaneal Sep 9 '16 at 13:12
  • 1
    Eeek, your system is old. I have upldefs.ltx 2016/06/29 v1.6e-u00. My guess is that is where the issue is. BTW, @egreg is a Mac user: this is not platform-specific. – Joseph Wright Sep 9 '16 at 14:16
  • 4
    I'm voting to close this question as off-topic because the issue was due to outdated software, solved by an upgrade. – egreg Sep 9 '16 at 21:07
  • 1
    I mean, the problem lies in the usage of dvipdfmx; command uplatex test.tex && dvipdfmx -f uptex-ipaex.map test.dvi can embed IPAex font even with the old system. This is the right solution for this question from Japan. (TeX Live 2016 does the similar thing by default using updmap, but 2015 or earlier does not.) – Hironobu YAMASHITA Sep 14 '16 at 7:06

Browse other questions tagged or ask your own question.