3

This code

\documentclass{article}

\usepackage{graphicx}

\begin{document}
    \begin{figure}
        \includegraphics{tiger}
    \end{figure}
\end{document}

is producing a blank page for me.

log output:

This is XeTeX, Version 3.14159265-2.6-0.99996 (MiKTeX 2.9 64-bit) (preloaded format=xelatex 2016.9.6)  9 SEP 2016 16:45
entering extended mode
**C:/projects/thesis/foo-thesis.tex
(C:/projects/thesis/foo-thesis.tex
LaTeX2e <2016/03/31> patch level 3
Babel <3.9r> and hyphenation patterns for 75 language(s) loaded.
("C:\Program Files\MiKTeX 2.9\tex\latex\base\article.cls"
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class
("C:\Program Files\MiKTeX 2.9\tex\latex\base\size10.clo"
File: size10.clo 2014/09/29 v1.4h Standard LaTeX file (size option)
)
\c@part=\count79
\c@section=\count80
\c@subsection=\count81
\c@subsubsection=\count82
\c@paragraph=\count83
\c@subparagraph=\count84
\c@figure=\count85
\c@table=\count86
\abovecaptionskip=\skip41
\belowcaptionskip=\skip42
\bibindent=\dimen102
) ("C:\Program Files\MiKTeX 2.9\tex\latex\graphics\graphicx.sty"
Package: graphicx 2014/10/28 v1.0g Enhanced LaTeX Graphics (DPC,SPQR)
 ("C:\Program Files\MiKTeX 2.9\tex\latex\graphics\keyval.sty"
Package: keyval 2014/10/28 v1.15 key=value parser (DPC)
\KV@toks@=\toks14
) ("C:\Program Files\MiKTeX 2.9\tex\latex\graphics\graphics.sty"
Package: graphics 2016/07/10 v1.0t Standard LaTeX Graphics (DPC,SPQR)
 ("C:\Program Files\MiKTeX 2.9\tex\latex\graphics\trig.sty"
Package: trig 2016/01/03 v1.10 sin cos tan (DPC)
) ("C:\Program Files\MiKTeX 2.9\tex\latex\00miktex\graphics.cfg"
File: graphics.cfg 2016/06/04 v1.11 sample graphics configuration
)
Package graphics Info: Driver file: xetex.def on input line 99.
 ("C:\Program Files\MiKTeX 2.9\tex\latex\graphics-def\xetex.def"
File: xetex.def 2016/07/11 v4.10 LaTeX color/graphics driver for XeTeX (L3/RRM/JK)
))
\Gin@req@height=\dimen103
\Gin@req@width=\dimen104
) (foo-thesis.aux)
\openout1 = `foo-thesis.aux'.

LaTeX Font Info:    Checking defaults for OML/cmm/m/it on input line 8.
LaTeX Font Info:    ... okay on input line 8.
LaTeX Font Info:    Checking defaults for T1/cmr/m/n on input line 8.
LaTeX Font Info:    ... okay on input line 8.
LaTeX Font Info:    Checking defaults for OT1/cmr/m/n on input line 8.
LaTeX Font Info:    ... okay on input line 8.
LaTeX Font Info:    Checking defaults for OMS/cmsy/m/n on input line 8.
LaTeX Font Info:    ... okay on input line 8.
LaTeX Font Info:    Checking defaults for OMX/cmex/m/n on input line 8.
LaTeX Font Info:    ... okay on input line 8.
LaTeX Font Info:    Checking defaults for U/cmr/m/n on input line 8.
LaTeX Font Info:    ... okay on input line 8.
File: tiger.eps Graphic file (type eps)
 <tiger.eps>
Overfull \hbox (205.05501pt too wide) in paragraph at lines 11--12
[][] 
 []


LaTeX Warning: Float too large for page by 38.1975pt on input line 12.

[1] (foo-thesis.aux) ) 
Here is how much of TeX's memory you used:
 599 strings out of 428408
 6776 string characters out of 3160625
 58967 words of memory out of 3000000
 4061 multiletter control sequences out of 15000+200000
 3640 words of font info for 14 fonts, out of 3000000 for 9000
 1328 hyphenation exceptions out of 8191
 25i,4n,19p,293b,236s stack positions out of 5000i,500n,10000p,200000b,50000s

Output written on foo-thesis.pdf (1 page).

the overfull hbox shouldn't be the problem, right?

some notes:

  • i tried this with an eps exported with libreoffice draw and two random eps files pulled from the internet.
  • if i have more text in there, it looks like it's actually reserving the correct space for the graphic, but putting nothing in it.
  • png files work fine.
  • in dvipdfmx.cfg, mgs.exe is enabled, not rungs or eps2pdf.
  • having said that, there is no conversion output file of any kind visible anywhere.
  • using e.g. [width=5cm] gets rid of the warnings but still, nothing shows up.

closed as unclear what you're asking by egreg, TeXnician, Moriambar, Troy, Stefan Pinnow Jun 8 '17 at 8:17

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    You get an Overfull \hbox with that code you posted? – Alenanno Sep 9 '16 at 15:08
  • Float too large for page ...? – cfr Sep 9 '16 at 15:11
  • Works for me (of course the box is overfull), but I'm not on MiKTeX. – egreg Sep 9 '16 at 15:14
  • @Alenanno yes, depending on the graphic that i include of course. – karyon Sep 9 '16 at 15:18
  • @cfr that's what it says, yes, but that shouldn't stop it from displaying something as far as i know. – karyon Sep 9 '16 at 15:19
0

Running xetex in the command line gave me the following output:

<snip>
(foo-thesis.aux) )stdin -> foo-thesis.pdf
[1
xdvipdfmx:warning: No image converter available for converting file "./graphics/Lighting_pipeline_concept_rough.eps" to PDF format.
xdvipdfmx:warning: >> Please check if you have 'D' option in config file.
xdvipdfmx:warning: pdf: image inclusion failed for "graphics/Lighting_pipeline_concept_rough.eps".
xdvipdfmx:warning: Failed to read image file: graphics/Lighting_pipeline_concept_rough.eps
xdvipdfmx:warning: Interpreting special command PSfile (ps:) failed.
xdvipdfmx:warning: >> at page="1" position="(133.768, 630.034)" (in PDF)
xdvipdfmx:warning: >> xxx "PSfile="graphics/Lighting_pipeline_concept_rough.eps" llx=0 lly"
<snip>

which was not shown in the log i saw. i don't know what causes the incomplete log, but i filed a bug in atom-latex which i used: https://github.com/thomasjo/atom-latex/issues/212

Regarding the actual problem:

Besides the dvipdfmx.cfg in C:\Program Files Miktex seems to put another dvipdfmx.cfg into the ProgramData directory. It was pretty empty (e.g. didn't contain the D option) and apparently completely overwrites the one in Program Files. Removing that file in ProgramData fixed the problem. I filed https://sourceforge.net/p/miktex/bugs/2527/ for this.

  • Given that your original code used tiger, it isn't surprising it didn't show these errors. It makes this much, much easier if the code you post produces the errors you report. – cfr Sep 9 '16 at 21:55
  • @cfr as i said i tried this with multiple eps files to rule out a problem with a specific file. it was the same problem with all the files, and the same solution with all the files. – karyon Sep 10 '16 at 12:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.