Today i tried to compile document with eskdtext documentclass. MiKteX suddenly turns on and starts something to download. It was eskdx package, as i think, but last update of eskdx was a year ago. After this happening, every time when i try to compile document, which uses eskdx i got 5 errors in row, but pdf file nonetheless produces alright. This did not happen before.

enter image description here I got those errors even when i try to compile


i did not find something understandable in log file, maybe I lack experience for this. I tried to reinstall MiKteX, but it did not help. Any ideas why it happening? http://pastebin.com/EgCN5Dpm there is my log file.

Update: i tried to compile same files with portable version of MiKteX, that contained in my flash drive and they compiled without errors.

  • I have added language option ukrainian to \documentclass such as, \documentclass[ukrainian]{eskdtext}, it is ok.
    – user31034
    Commented Sep 10, 2016 at 13:39
  • it is best to look at the log file, unfortunately the error summary in texstudio is very confusing. \bein{document} is just the location in the main file where the error occurred, the real error message from TeX would show you what the undefined command is (most likely a command in the .aux file that is read at \begin{document} Commented Sep 10, 2016 at 13:49
  • The command \No used by the class is undefined. I don't know what the class thinks the command should do. You could add a suitable definition with \newcommand\No{whatever} Commented Sep 10, 2016 at 13:49
  • Amazingly, it works for me too. But the problem is that i got same errors with documents that previously was fine. At now they not. And i'm not ukrainian one, so it unacceptable in that case. I began to suspect that the problem in the 'babel' package or something. Commented Sep 10, 2016 at 13:54

2 Answers 2


The correct setup for this class according to Title indentation after linebreak seem to be


At least it produces a bureaucratic looking form in Russian.

Alternatively, the following definition also works (found here):

  • I managed it myself but nevertheless thank you! This case has arisen because log file said nothing about support of \No. It confused me. Before in that case i got errors about \No so i fix it fast. Commented Sep 10, 2016 at 14:41

I want to complement gernot's answer. It will be useful for future decision-seekers. I would mark this qestion with eskdx's tag for greater clarity but i cant. In some version of babel package was deleted support of \No. It can be fix two ways:

Globally, if u add this code in file


\MiKTeX 2.9\tex\latex\babel-russian\russianb.ldf

Locally, if u add \newcommand{\No}{\textnumero} in the preamble of document.

  • It is not advisable to modify files in the general tex tree, since these chages are gone with the next update. If you add the definition to your preamble, I'd rather go for the more elaborate version that you propose to put into russianb.ldf or that I have suggested since it will work in all settings, whereas the short version will not.
    – gernot
    Commented Sep 10, 2016 at 15:08
  • Well, i just shared my knowledge. As i was convinced it was wrong. Commented Sep 10, 2016 at 15:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .