15

I cannot figure out how to make my citations appear with a simple number between brackets, like [1]. I obtain: "author et al. [year]" I use the documentclass book with natbib-package.

Edit1: I tried \citet{key} instead of \cite{}, it has no effect.

4
  • 1
    See section 3.1 of the natbib documentation (or texdoc natbib on your system). If you are still stuck after that, just update your question and we will try and help. Commented Sep 11, 2016 at 21:18
  • Question edited.
    – Jack
    Commented Sep 11, 2016 at 21:24
  • Which bibliography style do you use?
    – Mico
    Commented Sep 11, 2016 at 21:28
  • this should also answer your questions in addition to @AndrewSwann's comment: tex.stackexchange.com/questions/63855/…
    – naphaneal
    Commented Sep 11, 2016 at 21:42

2 Answers 2

11

You haven't specified which bibliography style you use. Assuming it's a style that can generate both numeric-style and authoryear-style citation call-outs -- some bibliography styles can generate only the latter type... -- you should load the natbib package with the option numbers. Alternatively, issue the instruction

\setcitestyle{numbers}

after loading the natbib package.

1
  • 2
    How do you go about it when you only want to do it for a specific citation and not all of them?
    – S P Sharan
    Commented Jan 27, 2022 at 9:31
6

Try using

\usepackage[square,numbers]{natbib}

or

Look at the link: https://www.overleaf.com/learn/latex/bibliography_management_with_natbib

It is explained very clearly over there!!

1
  • 3
    Instead of posting a link, could you describe the key points in this answer?
    – TobiBS
    Commented Sep 7, 2020 at 8:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .