2

I tried to submit a LaTeX file to arXiv. It failed and gave me this error message:

! Package auto-pst-pdf Error:
"shell escape" (or "write18") is not enabled:
auto-pst-pdf will not work!
.

See the auto-pst-pdf package documentation for explanation.
Type H <return> for immediate help.
...

l.134 Or turn off auto-pst-pdf.}
%
?
! Emergency stop.
...

l.134 Or turn off auto-pst-pdf.}
%
! ==> Fatal error occurred, no output PDF file produced!

In the past, I could upload to arXiv files with PSTricks code with no problem. What happened?

UPDATE (2019): Previously there was a workaround – one could submit a paper without \includegraphics commands and then the auto-pst-pdf would not check for the --shell-escape flag. But now, arXiv have moved to TeXLive 2016, which always checks for the --shell-escape flag. So now this workaround does not work.

What can I do? Should I convert every single pspicture (I have many) to a .png file? Or is there an easier solution?

SECOND UPDATE: I asked the staff at arXiv, and they suggested that I just comment out the line "\usepackage{auto-pst-pdf}". I did it, and indeed without this line, the file compiles fine on arXiv. However, without this line it does not compile on my computer - I get errors "Undefined control sequence" on \psframe. This is strange since I have TeXLive 2016, just like arXiv. How can I make my file compile without auto-pst-pdf?

  • I suppose that they are using latex->dvips->ps2pdf. In such a case you do not need the auto-pst-pdf package. – user2478 Mar 9 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.