0

I am doing citations for my master thesis which I just started writing in LyX. How do I cite my references like this: (author, year)? I have googled for like two hours now and nothing seems to work.

I tried to add \setcitestyle{aysep={<separator>}} in the preamble or round to documentclass and changing bibliography to natbib with option authoryear.

I have also tried adding natbib in the preamble, still no dice.

Any ideas are much appreciated. I am very new to LyX so I might need a little elaboration.

6
  • Which bibliography style do you employ? Hint: Not all bibliography styles are capable of producing authoryear-style citation call-outs.
    – Mico
    Commented Sep 13, 2016 at 20:01
  • Currently it is Natlib Author-year, it gives me the following types of citation: Author (Year)
    – no nein
    Commented Sep 13, 2016 at 20:05
  • Let me be more specific: Do you have a \bibliographystyle instruction somewhere in your document? If so, what's the argument of \bibliographystyle?
    – Mico
    Commented Sep 13, 2016 at 20:06
  • No, I do not. I have only changed things in the setting GUI menu.
    – no nein
    Commented Sep 13, 2016 at 20:08
  • If there's no \bibliographystyle instruction, BibTeX won't know how it should format the bibliographic entries...
    – Mico
    Commented Sep 13, 2016 at 20:11

3 Answers 3

1

You should

  • use a bibliography style that can generate authoryear-style citation call-outs,

  • load the natbib package with the option authoryear, and

  • use the instruction \citep to generate "parenthetic" citation call-outs, e.g., (Author, Year), and use \citet to generate "textual" citation call-outs, e.g., Author (Year).

Note that some bibliography styles cannot generate authoryear-style citation call-outs. E.g., plain, abbrv and unsrt can generate only numeric-style citation call-outs. (Use plainnat, abbrvnat, and unsrtnat instead...)

5
  • I am sorry for what is most likely a dumb question, but how would I load the natbib package with that option? I have that on in the settings under Bibliography
    – no nein
    Commented Sep 13, 2016 at 20:06
  • @nonein - \usepackage[authoryear]{natbib}.
    – Mico
    Commented Sep 13, 2016 at 20:07
  • Add this under the preamble I assume?
    – no nein
    Commented Sep 13, 2016 at 20:08
  • @nonein - Indeed, all \usepackage instructions must occur in the preamble.
    – Mico
    Commented Sep 13, 2016 at 20:09
  • I think I might be in love! It works, I do however have to add \citep in a latex code box. But I suppose that will do! Thank you very much1
    – no nein
    Commented Sep 13, 2016 at 20:10
2

Rather than messing around with the preamble, if simple Author-year citations is all you need they can be configured in the document settings.

Lyx settings to enable author-year citations

If you need more customization than that you should probably start looking at biblatex. That however is not straightforwardly integrated into Lyx and if you intend to customize you'll need to know at least some basic (La)Tex.

0

A. Generate a BibTeX bibliography using a program like JabRef. Enclose in curly brackets any letter that should be capitalized in any style: The ideas of {A}dam {S}mith. Save the .bib file, for example, in the folder of the LyX document.

B. Go to the end of the document and in an empty Standard paragraph Insert > List > BibTeX Bibliography> Add > Browse and choose the .bib file generated before. Press Open and Add. Under Style choose any of the following: agsm, apalike, authordate1, ..., authordate4, chicago.

C. Go to Document > Settings...

  1. In Modules, make sure that no module like natlibapa has been added

  2. Go to Bibliography. Under Citation Style choose Style format: Natlib (BibTeX), Variant: Author-year. Under Bibliography Style, choose as Default BibTeX Style: the one the following that you chose in B: agsm, apalike, authordate1, ..., authordate4, chicago. Under Bibliography Generation, choose Processor: bibtex8.

That's it.

If you want more details like doi in your list of references, then change the previous as follows:

B. Go to the end of the document and click the BibTeX Generated Bibliography. Choose Style: apacite.

C. 1. Go to Modules and add natlibapa.

C. 2. Go to Bibliography. Under Bibliography Style, choose Default BibTeX Style: apacite.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .