3

I'm trying to compile an image done with pstricks but everytime I run it I get the message "I can't find the file 'pst-arrow. ...rrowLoaded\endinput\else\input pst-arrow'"

The thing is... a long time ago I run this code and it was fine. Now I have to modify it but this message keep showing up. And I did not even change anything. I used the pstrick-add package. Thought this would be enough.

I'm using texmaker with MikTex 2.9. Can somebody help me?

Thank you.

Example:

\documentclass{article}

\usepackage{pstricks-add}

\textheight=25cm
\pagestyle{empty}

\begin{document}

\psset{arrowscale=3}

% Lines (\psline macro)

 \begin{pspicture}(2,1)
 \psline[ArrowInside=->]{<->}(2,1)
 \end{pspicture}


\end{document}
  • How are you loading pst-arrow? Are you only loading pstricks-add? Please provide a minimal example that replicates the current erroneous behaviour. Note that there was a recent change in terms of pst-arrow. All the arrow-related code was removed from pstricks-add. – Werner Sep 13 '16 at 20:22
  • I included \usepackage{pst-arrow} and still nothing. Do you have any idea where in the miktek file should the arrow.sty be? – Gabu Sep 13 '16 at 20:34
6

As @Werner pointed in his comment, there has been a recent change in the organisation of pstricks-add. You should install pst-arrow via MiKTeX Package Manager. Don't forget to synchronise the Package Repository first:

enter image description here

  • 1
    I looked for pst-arrow in the package manager but nothing shows up. – Gabu Sep 13 '16 at 20:38
  • 3
    Go to Package Repository and ask to Synchronise to update the database of packages. Probably also launch the Update manager. – Bernard Sep 13 '16 at 20:47
  • If you have any other problems, you might need to update your MikTeX installation. Use the "MikTeX Update (Admin)" application to do that. It is possible you will have to run this update twice until it is fully updated. – Augustin Jan 14 '18 at 18:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.