Here is a MWE:






When I compile my document on the arxiv website, I get the following errors:

! LaTeX Error: Option clash for package hyperref.


l.6 \begin
! Emergency stop.

l.6 \begin
No pages of output.
Transcript written on arXivSubmission.log.

Seems bizarre that having a single package in the preamble causes an error.

  • 1
    In my case it turns out that it was because I am using texlive 2018 version and arxiv is using 2016 version. So the bbl file I uploaded does not work for arxiv. In the end, instead of install texlive 2016, I uploaded my project to overleaf.com and compiled it there. This solves my problem. Commented Jan 30, 2019 at 14:31

1 Answer 1


When you use the document class article, arXiv additionally loads by default Babel, hyperref, hobsub-hyperref, hobsub-generic, keyval, ifxetex, kvoptions, url, rerunfilecheck, nameref, and gettitlestring (all from the texlive 2016 version).

This means that, oddly enough, arXiv would compile without trouble the following document:





Even if it uses the \url macro without loading the url or hyperref packages. Of course, if you try to compile this document on your installation, you would get an error:

! Undefined control sequence.
l.5 \url

But arXiv processes it just fine, without throwing any error.

Hence, you have two options:

  1. Ignore the error. It occurs only the first time arXiv compile your document (it compiles it multiple times), and don't impact the rendering. But careful, for this error might hide other problems (cf. the comments on this thread).
  2. Remove the hyperref package from your preamble. This is an odd solution, since you won't be able to compile your document on your installation, but it works, i.e., the document is compiled without throwing an error.


More help can be found at Arxiv's Considerations for TeX Submissions and at Common Mistakes that cause Automated Processing to Fail webpages. Also, reasons to submit the tex sources are listed at Why Submit the TeX/LaTeX Source?.

According to this source, starting 2017-02-09, ArXiV uses TeXLive 2016, after my answer was written, so I doubt it is in need of a modification.


Still according to this source, starting 2020-10-01, ArXiV uses TeXLive 2020, so my answer may need some adjustments.

  • 3
    Where did you find this information about what arXiv automatically loads? Commented Mar 24, 2017 at 2:35
  • 4
    I just read the .log file, that they share with you in any cases.
    – Clément
    Commented Mar 27, 2017 at 13:24
  • I am using JMLR template which have own style file, and trying to upload the manuscript to arXiv. I have also removed hyperref from the manuscript but still I am getting the same error. Commented Apr 20, 2019 at 14:03
  • I found the error for my case. Even after removing 'hyperref', the error message did not go but there were some missing files also. So when I added those files, it worked. (missing files have their own story but don't want to make things more complex. just want to say somehow eps was working so added pdf versions). Commented Apr 20, 2019 at 14:49
  • 2
    It appears to me that arXiv has changed its configuration: After removing hyperref from my source, I get the expected "Undefined control sequence" error for url. This answer might be obsoleted and hence need an update.
    – mfg
    Commented Apr 23, 2019 at 14:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .