0

I've worked with TeXmaker for several years now, but it doesn't work anymore. Last month, I had to completely reboot my computer. I use now Ubuntu 16.04LTS, which is a dual boot.

So I installed Texmaker (sudo apt-get install texmaker)... and surprise surprise: i cannot make compilations of files.tex The fact is that I can't compile my own files, which were compiled by my own laptop.

I have several issues, listed below:

  • Use of moderncv: cannot find the file fontawesome.sty. I could compile this cv.tex before, though. I copy it in /usr/share/texlive/texmf-dist/tex/latex/moderncv/... But still doesn't work.
  • Normal use: I tried to write a short and simple text. I also tried to compile some of my previous works (only writing things). The package babel is not recognized -> frenchb, french, français, and even english are not considered as languages.

So here I am. I've got plenty of files.tex that compiled well before, but not anymore.

You would be very nice if you could help me with this stuff.

closed as off-topic by Przemysław Scherwentke, user13907, Ronny, Zarko, Thorsten Sep 23 '16 at 12:28

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Just go to Package Manger Directory and install the desired packages, to make it behave normally. – Mishra S Sep 14 '16 at 10:46
  • 2
    TeXmaker is just an IDE, that is a software with embedded features that makes it more easy to use that a plain notepad (e.g. gedit). However, it is just a more convenient way to write the source-file of your document, nothing more. To process it (i.e. generating a PDF from your .tex file, you need to install (La)TeX software on your computer. I recommend you to install it via TeXlive (but from the sources in order to have the 2016 version, what is not the case with sudo apt-get install texlive-full). – ebosi Sep 14 '16 at 11:38
  • 1
    @Loïc then you should have a look at the first line of the created .log file to know which engine you use. – ebosi Sep 14 '16 at 14:21
  • 2
    Thus, I suggest you to uninstall MikTeX, and do a fresh install of TeXlive (moreover, you'll then update from the 2015 to the 2016 version and so benefit from package updates) – ebosi Sep 14 '16 at 14:25
  • 4
    I'm voting to close this question as off-topic because problem was solved by reinstalling the software. – Przemysław Scherwentke Sep 23 '16 at 11:10
1

Based on information detailed in comments, I suggest you to do a fresh install of the new release of TeXlive.

Note Dai Bowen's comment hereinabove:

If reinstalling doesn't seem to do the job, try following How to remove everything related to TeX Live for fresh install on Ubuntu? and How to install “vanilla” TeXLive on Debian or Ubuntu?. The moderncv problem may be font-installation specific but babel problems are (likely) something else.

  • Deleted, installed, and PATH done. But when i compile the MWE, i have the same version in my .log (2015). And of course, more complex compilations don't work at all. – Loïc Sep 14 '16 at 15:43
  • Babel problem is solved using this: tex.stackexchange.com/questions/139700/… – Loïc Sep 14 '16 at 19:09
  • I copy the 'fontawesome.sty' file into /usr/share/texlive/texmf-dist/tex/latex/moderncv/. I run \updmap and... Not the same issue when compiling. Now, the file 'fontawesomesymbols-generix.tex' is missing. I tried the same technic with this file, but unfortunately, it doesn't work. I have the impression that the moderncv package i have is not working well... PS: \moderncvstyle{casual} does not work, but \moderncvstyle{classic} works. – Loïc Sep 14 '16 at 20:22
  • @Loïc well, it seems somehow strange to me. To force your system to run TeXlive 2016 when compiling, you could uninstall TeXlive 2015 (if your sure your TL2016 install is full and working). – ebosi Sep 15 '16 at 7:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.