0

When I compile, the images (.jpg and .png) inserted in my tikzposter document don't display - I just get a box with the image path instead. It looks like this:

enter image description here

Existing answers to similar questions (Why is the picture not inserted?, Images not showing up and Images not visible in PDF) haven't worked for me.

The images did display in this document before, and I can't figure out what I did to stop them showing up.

I've tried commenting out most of the preamble lines individually, but with no success.

Any help would be greatly appreciated.

Here's my MWE:

\documentclass[25pt, a1paper, landscape]{tikzposter}
\usepackage[utf8]{inputenc}
\usepackage{graphicx}


\title{Title}
\author{Name}
\date{\today}
\institute{Institution}

\usepackage{blindtext}
\usepackage{comment}
\usetheme{Basic}


\begin{document}

\maketitle

\begin{columns}

\column{0.33}
\block{Column 1}{

\begin{tikzfigure}[Test\label{here}]
\includegraphics[width=0.33\colwidth]{images/Test.png}
\end{tikzfigure}

 }

\end{columns}

\end{document}
  • Are you sure you are using this code? It works for me with example-image.png instead of images/Test.png. – Ignasi Sep 15 '16 at 7:22
  • I'm using Sharelatex (www.sharelatex.com). I definitely have this code not producing the image. But - when I copy the code into a new 'project' and try again, it works perfectly. Could it be a problem with some of the other files I have in this project? All I have are the images folder and three .tex files (one for testing pictures and one for snippets of unused code). If not, I guess maybe it's a problem with Sharelatex rather than my code. – Owain Sep 15 '16 at 7:32
  • I should also have mentioned that I'm getting this error message: Package tikzposter Warning: Unknown Option draft. on input line 204. I don't get this error in the separate 'project', however. So is this the culprit? – Owain Sep 15 '16 at 7:36
  • OK, I solved this by copying all my code and files into a new 'project'. The images now work perfectly and the error messages don't reappear. Since nothing else has changed I assume this is a bug with Sharelatex so I'll close this question. – Owain Sep 15 '16 at 7:46
  • 2
    draft option is the culprit. draft option from graphicx does the result you get. Some of your files introduces it. – Ignasi Sep 15 '16 at 7:47
1

Answered as above. Solved by moving all code and image files to a new Sharelatex 'project'. I assume it's a bug with Sharelatex so I'll report it accordingly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.