1

I have been generating my plots directly in my .tex files for a while. This all works fine if I open the pdf generated by pdflatex, however, I have noticed that if I print (hardcopy) or just export that pdf to a new one, all my contours disappear (the axis are still there).

The code I use is:

\begin{tikzpicture}
\begin{axis}[
width=0.8\textwidth,
height=0.33\textwidth,
axis equal,
view={0}{90},
colormap/hot2,
colorbar,
colorbar style={
scale only axis,
yticklabel style={
align=right,
/pgf/number format/.cd,
fixed,
try min ticks=6
}}
]
\addplot3[raw gnuplot,surf,shader=interp]
gnuplot[id={surf}]{
set parametric;
set pm3d;
splot 'data/field/tkemean.dat' u 1:2:(($3)/2.0)
};                
\fill [gray, thick] (axis cs:-0.5,0.0) rectangle (axis cs:0.5,0.5);
\end{axis} 
\end{tikzpicture}

Both the colorbar and the rectangle "survive" the print, but the contour disappears.

Anyone has come across this issue?

closed as off-topic by Stefan Pinnow, Mensch, barbara beeton, Schweinebacke, percusse Jul 24 '17 at 20:46

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • After creating the PDF there is nothing related to the source anymore. Your printer might have a quirk instead. – percusse Sep 16 '16 at 10:13
  • @percusse well that was my first thought, but it will also happen if I use a virtual printer to export the document. I have tried with multiple printers and on mac, windows and linux computers, all have the same issue. here's the example if you want to try: original image: dropbox.com/s/25n99kva1d790ko/Figure14_original.pdf?dl=0 printed to a new pdf: dropbox.com/s/w6bmwe7qlmiyyjd/Figure14_printed.pdf?dl=0 – Felipe Sep 16 '16 at 10:16
  • Please edit your question so that it includes a complete example, from \begin{document} to \end{document}. This will make it easier for other users to help you. – Ian Thompson Sep 16 '16 at 15:25
  • 4
    I'm voting to close this question because the data files are no longer available and thus it is very unlikely that the question can be solved. – Stefan Pinnow Jul 24 '17 at 20:02
  • I have "fixed" this by running the chain (on a Mac): pdf2ps ps2eps epstopdf But no clue what was causing the problem... – Felipe Jun 5 '18 at 21:29