1

Using the beamer document class, I would like to split a long list of references over multiple slides. As recommended by M. Tibbits in another stack exchange question, one should use allowframebreaks. This, however, resulted in two unnecessary page breaks after the final slide before the appendix. See the working example below. Note that if [allowframebreaks] is removed, then the two phantom pages disappear.

Question: Why do the phantom pages appear, and how do I get rid of them?

\documentclass{beamer}
\usepackage[unnumberedbib,bibnewpage]{apacite}

\begin{document}
\begin{frame}
\frametitle{Title}
\begin{itemize}
\item This is a citation \citeA{citation1}
\item This is another citation \citeA{citation2}
\end{itemize}
\end{frame}

\appendix
\begin{frame}[allowframebreaks]
\bibliographystyle{apacite}
\begin{flushleft}
\bibliography{stack_exchange_library}
\end{flushleft}
\end{frame}
\end{document} 

My library, stack_exchange_library.bib, is:

 @article{citation1,
  title={Title of citation 1},
  author={Smith, John},
  journal={Blacksmithing},
  year={2010},
}

@article{citation2,
  title={Title of citation 1},
  author={Farmer, Joe},
  journal={Farming},
  year={2011},
}
2

Remove bibnewpage from the apacite options. In normal text documents this triggers the bibliography to be on a new page, but this does not make sense in beamer as you are already in a new frame.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.