When compiling the document


using xelatex I obtain the error

xdvipdfmx:fatal: Cannot proceed without the font: /usr/share/font/woff/scheherazade/Scheherazade-Regular.woff

Apparently the fonts are not part of TeXLive 2016, so I downloaded Scheherazade-2.100.zip from SIL International, unpacked it into /usr/local/texlive/texmf-local/fonts/truetype, and ran mktexlsr. According to Installing TeX fonts I am now supposed to run updmap on a .map file, but there is none.

So my questions are:

  • How does this .map look like, where do I get it from?
  • Is there anything else missing for setting up the font correctly?

Edit: Apparently my Ubuntu installation already contained the Scheherazade fonts from installing the package fonts-sil-scheherazade, which puts them at /usr/share/fonts/woff/scheherazade/. When adding the link /usr/share/font -> /usr/share/fonts (there was no font before), xelatex/xdvipdfmx somehow takes notice since it corrects the path in the error message from font to fonts, but otherwise still the same.

  • 2
    You don't need map-files or updmap. It looks as if xetex is finding the wrong font. Try to use the filename: {Scheherazade-Regular.ttf} Sep 18, 2016 at 15:30
  • 1
    I literally had the same problem @UlrikeFischer's solution is the way to fix it. The .woff version is a different version of the font that XeTeX can't really work with. P.S. as a bonus, I recommend scaling scheherazade as I find it's very small in its default size. Play around with \newfontfamily{\AR}[Script=Arabic,Scale=1.7]{Scheherazade-Regular.ttf} and see if it suits your taste
    – Au101
    Sep 18, 2016 at 15:34
  • @UlrikeFischer Thanks, this solved the problem!
    – gernot
    Sep 18, 2016 at 15:41
  • 1
    You should uninstall the WOFF version of the fonts, these are meant for use on the web and XeTeX does not support them. Oct 3, 2016 at 14:00

1 Answer 1


You should uninstall the WOFF version of the fonts, these are meant for use on the web and XeTeX does not support them.

It seems that XeTeX (the engine) will happily process WOFF files since it uses FreeType to load the fonts and FreeType supports WOFF fonts, but dvipdfmx (the output driver) does not support them and will give the error you got (the wording is slightly misleading, it did find the font specified but it does not know how to process it).

  • This worked for me; I just deleted /usr/share/fonts/woff, although it would have been nice if I could configure XeTeX to just not look there. Thanks!
    – goodmami
    Dec 7, 2016 at 23:04
  • 1
    @goodmami: XeTeX uses FontConfig in Linux, you can blacklist certain font directories, though I’m not sure it can be done per-application. My suggestion would be to file a report against your Linux distribution, installing the same font in various formats system-wide is always a bad thing, not to mention that WOFF is intended for use om the Web, Dec 15, 2016 at 5:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .