0

I'm using MacTex on OS X 10.11. I recently installed BasicTex in an attempt to get Anki to be able to use Latex for math notation, which worked.

However, when I try to use Latex normally, it breaks on things that worked before. So far I've noticed:

  • it gives an "undefined control sequence" error on certain math symbols, eg \diamond
  • it errors trying to import custom .sty files that were working before and haven't moved

All I can think of is somehow installing BasicTex overwrote the settings for MacTex somehow, but I can't find anything about this anywhere. I've checked that my latex command is using the binary from the 2016 installation and not the 2016basic installation, and it is. All my packages (amsmath, etc) are still installed in the right place, though for some reason Tex Live Utility doesn't show a list of packages when I open it. Does anyone know what could be going on or where I should check to figure it out? Thanks!

  • Welcome! BasicTeX is a subset of MacTeX. Why exactly did you need to install both? – cfr Sep 19 '16 at 14:48
  • Anki was giving dvipng errors when I tried to just use MacTex. I could only find people describing having it working with BasicTex, so I tried installing that, and it worked. – litvyak Sep 19 '16 at 15:30
  • 1
    BasicTeX does not bundle with dvipng, so it is even more surprising that it works when your error with MacTeX is a dvipng error. It would be perhaps better for you to uninstall both BasicTeX and MacTeX, reinstall MacTeX, and then ask about the dvipng error you see. – Willie Wong Sep 19 '16 at 17:37
  • In any case, when you go into "Configure" in TeX LIve Utility and select "Reconfigure distribution", which distribution is it showing? – Willie Wong Sep 19 '16 at 17:37
  • Yes; to get dvipng working I installed dvipng and BasicTex. TeX Live Utility does not have any "reconfigure distribution" option under "configure", but under "Change default TeX Live version" it has texlive-2016 selected. – litvyak Sep 19 '16 at 18:35
1

After you installed BasicTeX the links that were set to find the active distribution pointed to the BasicTeX distribution you need to use TeX Live Utility to reset the active distribution to be you TeX Live 2016.

0

As @Willie Wong suggested, I deleted my /usr/texlive/2016 directory and reinstalled MacTex. This fixed all my problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.