5

This question already has an answer here:

This is recent behavior, but I couldn't figure out since exactly when this is happening:

% !TEX encoding = UTF-8 Unicode
% !TEX TS-program = pdflatexmk
\documentclass{beamer}

\usepackage{filecontents}

\begin{filecontents}{foo.bib}
@misc{Fallick2004a,
author = {Fallick, Bruce and Fleischman, Charles A.},
title = {{Employer-to-Employer Flows in the U.S. Labor Market: The Complete Picture of Gross Worker Flows}},
url = {http://www.federalreserve.gov/econresdata/researchdata/feds200434.html},
year = {2004}
}
\end{filecontents}

\usepackage[
    backend=biber,
    style=authoryear-comp,
    natbib=true
]{biblatex}
\bibliography{foo}
\begin{document}

\begin{frame}
\citet{Fallick2004a}
\end{frame}
\end{document}

Output:

Fallick and Fleischman, (2004)

This happens for all sorts of references, but only textcite and citet, not citep. I tried re-installing

sudo apt-get install texlive-full

to no avail.

marked as duplicate by moewe biblatex Sep 26 '16 at 13:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    I cannot reproduce the problem on a TeXlive 2016 installation. I get the reference without comma. – gernot Sep 19 '16 at 15:24
  • Consider removing the texlive packages from Debian/Ubuntu and installing the latest TeXLive distribution separately. – gernot Sep 19 '16 at 15:26
  • 3
    This was an issue in an older version of biblatex. It is fixed now, you should consider updating. (If you use the repository version of TeX live, which often is outdated, you could consider switching to a "vanilla" TeX live: How to install “vanilla” TeXLive on Debian or Ubuntu?). See github.com/plk/biblatex/issues/373, I can't reproduce your output with biblatex 3.5 – moewe Sep 19 '16 at 15:29
  • @AlanMunn I used the document code as given and ran pdflatex, biber, pdflatex, pdflatex (without options to the commands, but with natbib=true for the biblatex package). I installed TL2016 only today, so maybe it is a recent change? I have biblatex 2016/09/17 v3.6 installed. – gernot Sep 19 '16 at 15:33
  • @moewe Clearly not up-to-date. :) I'm updating now on this machine; I see there's a biblatex update, so I assume it will be fixed. (Yes, fixed now.) – Alan Munn Sep 19 '16 at 15:35

Browse other questions tagged or ask your own question.