0

My equation reference is appearing immediately after my equation such that it looks like I'm multiplying my first equation by (1). How do I get the equation number to align to the right-hand-side of the page?

\begin{equation} \label{eq:dropweight}

W_{drop} = g\frac{m_{measured}}{#\, of\, drops} = f (2\pi r) \gamma \end{equation}

closed as unclear what you're asking by Werner, user13907, Andrew, barbara beeton, Stefan Pinnow Sep 20 '16 at 4:52

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    This surely is not the default. Can you provide us with your preamble as well as a single equation that replicates the result? – Werner Sep 19 '16 at 18:37
  • by default the equation number will be flush to the right edge of the text block, but also don't use math italic for multi-letter words, {measured} should be {\mathrm{measured}} and {#\, of\, drops} (which by default would give an error) should be {\textrm{\# of drops}}` – David Carlisle Sep 19 '16 at 18:41
  • Okay, here is what I have: \documentclass{article} \usepackage{amsmath} \begin{document} \begin{equation} \label{eq:dropweight} W_{drop} = g\frac{m_{measured}}{\#\, of\, drops} = f (2\pi r) \gamma \end{equation} – Lauren Sep 19 '16 at 19:01
  • @Lauren add it to a code block ({} button in the editor) in your question, code in comments doesn't work and loses all line endings and other formatting – David Carlisle Sep 19 '16 at 19:05
  • @Lauren: As it stands it's not possible to duplicate your problem. I've voted to close this as unclear. Until you add a minimal example that replicates your problem, answers to this question is based on pure speculation. – Werner Sep 19 '16 at 20:38
2

Your document

enter image description here

\documentclass{article}



\begin{document}

\begin{equation} \label{eq:dropweight}
W_{drop} = g\frac{m_{measured}}{#\, of\, drops} = f (2\pi r) \gamma 
\end{equation}
\end{document}

generates an error

! You can't use `macro parameter character #' in math mode.
<argument> ##
             \, of\, drops
l.8 ...rop} = g\frac{m_{measured}}{#\, of\, drops}
                                                   = f (2\pi r) \gamma
? 

After an error you should not really look at the pdf file, TeX makes no attempt to make sensible output, it just recovers to check the rest of the file.

You need \# for # but also multi-letter words should never be set in math italic (which is designed to make them look like a product of variables not a word)

\documentclass{article}

\usepackage{amsmath}

\begin{document}

\begin{equation} \label{eq:dropweight}
W_{\mathrm{drop}} = g\frac{m_{\mathrm{measured}}}{\textrm{\# of drops}} = f (2\pi r) \gamma 
\end{equation}
\end{document}

enter image description here

actually the error was probably from the blank line:

! Missing $ inserted.
<inserted text> 
                $
l.8 

? 
! Display math should end with $$.
<to be read again> 
                   \par 

depending on quite how the original document looked

  • The OP does appear to have written \#, not just #, in the denominator. However, he does have a blank line in the equation environment, which will through a different error if amsmath is loaded. – Mico Sep 19 '16 at 18:47
  • Yep, beat me by two seconds there @Mico... – Guilherme Zanotelli Sep 19 '16 at 18:49
  • @Mico looks like a bad edit by someone else, the OPs example had # – David Carlisle Sep 19 '16 at 18:49
  • @DavidCarlisle - Ah, I hadn't noticed that there had been an edit... – Mico Sep 19 '16 at 18:55
  • @Mico actually I'm not sure the original is a bit garbled by not beining a code block, but with # I get a pdf with (1) flush to the equation..... – David Carlisle Sep 19 '16 at 19:00
0

The subscript terms "drop" and "measured" as well as the text "# of drops" in the denominator should be all be typeset using upright-roman rather than math-italic lettering. I suggest you use \textnormal to typeset the terms.

If you load the amsmath package, you mustn't have a blank line in a displayed-math environment such as equation. Separately, do write \#, not just #, if you want to typeset a hashtag (aka octothorp) symbol.

Finally, I can't reproduce the issue you mentioned in the title of your posting, viz., the poor placement of the equation number. How wide is your text block? Please consider editing your posting to make the issue reproducible.

enter image description here

\documentclass{article}
\usepackage{amsmath}
\begin{document}
\begin{equation}\label{eq:dropweight}
W_{\textnormal{drop}} = g\frac{m_{\textnormal{measured}}}{\textnormal{\# of drops}} = f (2\pi r) \gamma
\end{equation}
\end{document}
  • you can't have a blank line even without amsmath, I think the close (1) is simply that the math mode had ended (see image I just added) – David Carlisle Sep 19 '16 at 18:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.