1

I have the same problem as this person before me: Texlua not be recognized

I want to install nonfreefonts via https://www.tug.org/fonts/getnonfreefonts/ When I'm entering texlua install-getnonfreefonts then the error occurs, that texlua is spelled wrong or could not be found.

Sadly the hint from the old question didn't help me and I'm not working on a Mac. I'm working with Windows 7 Enterprise on a Dell Latitude E7470 Ultrabook. It's a company device, so maybe I can't istall getnonfreefonts because I'm not the admin?

But my boyfriend also tried to install nonfreefonts on his private computer and he has the same problem even though he is admin on his computer.

Maybe someone has any idea? I googled the last two hours in german and english language and couldn't find an answer.

Thank you a lot, Kobold

  • 1
    What TeX system do you have installed? It's normally easiest to find that out by doing pdftex --version at the Command Line. – Joseph Wright Sep 20 '16 at 13:16
  • are the binaries in your path, what folder is texlua.exe in? (for me it is /usr/local/texlive/2016/bin/x86_64-cygwin/texlua.exe I'm not sure where the native windows texlive installs by default) that directory needs to be in your PATH, or you need to run from there – David Carlisle Sep 20 '16 at 13:16
  • @DavidCarlisle default on windows usually is c:\texlive\year\... – daleif Sep 20 '16 at 13:32
  • I have TexLive and TexMaker installed. – Kobold Sep 23 '16 at 8:56
1

Okay, I found it out by myself.
I opened the TexLive command-line (via Start->All programs->TexLive2016->TexLive command-line). Then I put the install-getnonfreefonts file in the folder tat is shown in the command-line.
And then it worked with texlua install-getnonfreefonts.
It was mainly @JosephWright 's hint to look for the system I have installed. Then I found the TexLive command-line. So thank you!!! And thanks to David Carlisle too!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.