I'm using Sublime 2 and the Latextools package, along with Skim as my .pdf viewer. Until this evening when I was notified of an installed Latextools update, I was able to hit command-B to build my document (with latexmk), and the changes would appear in the concurrently open file in Skim.

Now, there's no output in the sublime console, and the build option is greyed-out in my Tools menu.

Does anyone know how to fix this? While we're at it, can I prevent automatic updating of the Latextools package in the future?

EDIT: After reading this post, I think my build file must be broken. However, I don't know what/how to fix.

  • Welcome to TeX.SX! Can you give a minimal working example for your build file and a tex file. It is hard to troubleshoot this without more details. – Andrew Sep 21 '16 at 6:06
  • I actually can't give a minimal working example, because I can't build anything to output. I have exactly the same problem with the standard MWE \documentclass{article}\begin{document}hello\end{document}. – sourisse Sep 21 '16 at 11:06
  • Have you tried to restart ST? Have you an console error while starting Sublime Text? In general I would recommend to create an issue on github. – r-stein Sep 21 '16 at 11:32
  • I have restarted ST, and my console only shows errors with a MatLab syntax completion package. – sourisse Sep 21 '16 at 11:42

I have solved my problem: it turns out that for whatever reason, LaTeXtools was put into my list of ignored packages in my Sublime user settings file. Deleting the entry corresponding to it restored the functionality I had before.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.