0

I was wondering if anyone can give me any advice or help with the issue I have been encountering. About a year ago, MikTeX packages weren't installing (for some reason unknown). What I found was that if I simply press the "Enter" key enough times after it keeps asking me about packages I need to compile using WinEdt, I can still get my PDF to generate.

Along comes the update of Windows 10. Now nothing will compile. It basically just gives up and no PDF is ever generated. I went as far as to delete everything "MikTeX" on my computer that I could (apparently it found over 100,000 items to delete), and I even uninstalled every version of WinEdt that I had. I then downloaded the newest version of WinEdt, but when I tried to download MikTeX again, for some reason it gave me some bizarre error code telling me it couldn't be done (even after installation seemed to be completed).

Also, after I apparently deleted all of the MikTeX packages from the past, I still found the entire thing. I tried deleting those but it says it couldn't be deleted because it is still running in another program. What program could it be running in if I already uninstalled WinEdt?

I have a terrible knowledge about how computer software works, and I do not know computer jargon that well, so if someone could explain to me what is going on and how I can fix the problem in basic terms, it would be very much appreciated! Thanks!

  • Did you use a dedicated software to uninstall? They usually can check if there remains any traces of the program, and delete them. Also, WinEdt should be installed after MiKTeX. – Bernard Sep 26 '16 at 22:12
  • What do you mean a dedicated software? I simply when into "Apps and Features" and uninstalled WinEdt 7, 8, and 9. (And thanks for the tip.) – gorzardfu Sep 26 '16 at 22:14
  • Something like Revo Uninstaller, which can make a more thorough unstallation than Windows. – Bernard Sep 26 '16 at 22:18
  • @Bernard I'll see if that will work – gorzardfu Sep 26 '16 at 22:22
1

MikTeX under Windows can be finicky at times, but with WinEdt and SumatraPDF working with MikTeX, its an amazingly productive experience. Your post does not contain enough information to diagnose your problems so I would recommend that you uninstall your existing MikTeX, grab the most recent version of the MikTeX installer "basic-miktex-2.9.6069-x64.exe" assuming a 64-bit Win OS. I also recommend keeping an install journal, ie., write down the installer choices you make, especially who you install for (everyone or just you), the install location, package install on the fly, and paper size. If for no other reason, who'll get a glimpse of how Windows and MikTeX work. Understand that if you install for anyone, MikTeX installs on a system level and requires administrative privileges as does MikTeX Package Manager when you run future updates. Installing just for you does not require administrative privileges and is recommended. I would suspect your original problems stems from that. Someone mentioned Revo Uninstaller and I concur with that. There is a free version available and I use the Portable Apps version and its been very useful. It has a hunt feature which searches your registry and file system for left-over entries the program uninstaller may leave behind. If you have WinEdt already installed, there is a Options> Configuration menu item that will try to sort your MikTeX configuration for its configuration, otherwise install it after MikTeX. Hopefully, you can get things sorted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.