2

Could anybody give me some help on this problem I've come over?

\documentclass{article}
\usepackage{natbib}
\begin{document}
    \bibliographystyle{ormsv080}
    \bibliography{MST_TBS}
    \printbibliography
\end{document}

when compiling, I got the error:

! undefined control sequence
1.13 \printbibliography
8
  • 5
    natbib doesn't use/provide \printbibliography: the latter is part of biblatex, an alternative approach to natbib.
    – Joseph Wright
    Sep 27 '16 at 19:24
  • 4
    ... so you don't want to have both \bibliography{..} and \printbibliography. Just remove the latter. Sep 27 '16 at 19:25
  • Welcome to TeX.SX! Your MWE gets messed up by the inclusion of both biblatex & bibtex based commands, as @JosephWright points out. Also, \usepackage[style=<somebiblatexstyle>,<other options>]{biblatex}, \addbibresource[<options for bib resources>]{<mybibfile>.bib}% Syntax for version >= 1.2 are also missing from your MWE preamble. To get things working properly with biblatex, follow the following excellent links: tex.stackexchange.com/q/5091/78565 & sharelatex.com/learn/Bibliography_management_with_biblatex .
    – Amar
    Sep 27 '16 at 19:43
  • 1
    Possible duplicate of Undefined control sequence in \printbibliography (biblatex)
    – Amar
    Sep 27 '16 at 19:47
  • 1
    @Amar No, that is not a duplicate. Sep 27 '16 at 20:42
4

I assume the unformatted bibliographic entries are contained in the file MST_TBS.bib. Depending on whether you want to create the bibliography with either natbib (and BibTeX) or biblatex (and biber), you should use one of the following templates.

  1. natbib and BibTeX

    \documentclass{article}
    \usepackage{natbib}
    \bibliographystyle{ormsv080}
    \begin{document}
        ....
        \bibliography{MST_TBS} % note: no ".bib" extension
    \end{document}
    

    Assuming the main tex file is called main.tex, the compilation sequence is

    latex main
    bibtex main
    latex main
    latex main
    
  2. biblatex and biber

    \documentclass{article}
    \usepackage[<various options that replicate the settings of 
                 the "ormsv080" bibliography style>]{biblatex}
    \addbibresource{MST_TBS.bib} % note the ".bib" extension
    \begin{document}
        ....
        \printbibliography
    \end{document}
    

    Now, the compilation sequence is

    latex main
    biber main
    latex main
    
2
  • Isn't there a typo at \addbibresource{{MST_TBS.bib} (no closing })?
    – hola
    Jun 6 '17 at 2:14
  • @pushpen.paul - Thanks. Yup, that was a typo. :-(
    – Mico
    Jun 6 '17 at 3:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.