3

I've just installed TeXstudio on my machine. On my other machines, I have it so that moving the cursor up and down the plaintext/code (LHS) doesn't move the preview (RHS), but when I do "Build and View" the preview moves to show the same place as I'm at in the sample text, and the paragraph is temporarily highlighted in yellow.

I know there are the "scrolling follows cursor" and "cursor follows scrolling" buttons. I've tried them in all their different configurations (well, there are only four different configurations!), but these don't solve it -- in fact, these make no difference to any scrolling/following.

I've had a look at the "Build" and "Preview" parts of Configure too, to no avail.

Also, I've seen there's a post on here about how to disable "scrolling after compilation". This is exactly what I want enabled; unfortunately, I can't see how to enable it (even from that post)!

Any advice would be most appreciated!

  • Is there a file "[pdfname].synctex.gz" next to your pdf? Can you sync using "Go to PDF" / "Go to Source" from the editor / viewer context menu? – Tim Hoffmann Oct 1 '16 at 7:13
  • Hi Tim, thanks for your comment. I do have the file in question, but neither "Go to PDF" nor "Go to Source" do anything at all... – Sam OT Oct 1 '16 at 11:43
  • Is the synctex.gz file up-to-date, i.e. has the same creation date as the PDF? Does it happen with a simple minimal tex document? – Tim Hoffmann Oct 1 '16 at 12:39
  • The file wasn't up-to-date. I made a new document -- just took a template and put in \newpage then some words -- and it worked fine on that document, all the correct scrolling. I then loaded up my file and copied all the plaintext over to the new "untitled" document. All the scrolling worked fine. However, once I saved the file, it stopped working! ... :/ -- I don't even have the "Go to Source" option anymore. – Sam OT Oct 1 '16 at 15:03
  • Ok, I appear to have fixed it. I saved it again as "texfile" and it all works. I then gave it another (shorter) name (it had a long name before, which I thought might be causing the issue), but that broke it. I've found now that it works if the file name has no spaces in it, but doesn't work if it does; eg, "tex_file" would would work but "tex file" wouldn't. This is weird, since I've had other documents on other machines that do not suffer this issue... – Sam OT Oct 1 '16 at 15:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.