1

for a presentation I like to switch between several views of my 3D model. I'd like it to behave like slides, going through one view with each click.

I found an answer here, however this solution isn't working for me. I do get the error message:

Undefined control sequence.  \ThreeDPresSteps{{diceA,7},{diceB,7}} 

This might have to do with the used media9 version, as I too get the error that only "2015/08/18" is available (latest updates on my distribution). Replacing the media9 package by hand only brings me further down the rabbit hole, as I'll end up with "support outdated l3kernel too old" as error message.

Is there another solution or workaround? Maybe even a nicer way to change between views?

Thanks!

  • 1
    Welcome to TeX.SX! Please help us help you and add a minimal working example (MWE) that illustrates your problem. Reproducing the problem and finding out what the issue is will be much easier when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – user36296 Sep 30 '16 at 13:15
  • 1
    If it's really an issue with an outdated version, can you simply update your tex distribution? – user36296 Sep 30 '16 at 13:17
  • @samcarter: Thanks for the reply! I tried the linked code in the other thread, however I do get the mentioned error codes. From the comments it seems that only certain versions produce this error. I also don't really understand which part of the code produces these errors. The posted solution there seems also rather complex. So maybe there is (now) a better way to achieve this? I also can't comment on the original post due to missing reputation points. – John Miller Sep 30 '16 at 17:34
  • 3
    I tried the linked code and it works perfectly fine with up-to-date pdflatex from TeXlive2016. Can you update? [If your distribution is from mid 2015, it cannot work, as [2015/11/02] means it is explicitly loading this version of the package]. As far as I remember this feature to call a specific version was introduced last year, so maybe you distribution does not have it yet. – user36296 Oct 1 '16 at 16:07
  • 1
    Which TeX distributio do you use (TeX Live, MiKTeX, ...) and which version number has it (check the first line of the log file). Please add this informations to your question ... – Mensch Oct 1 '16 at 16:47
1

OK, finally got it running. I replaced all files mentioned here and then ocgx2, after a rerun of texhash /usr/local/share/texmf it seems to work, so far I haven't found other issues. Just hope it won't collide with my package manager in the future.

Also thanks to @samcarter for the help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.