1

I am using biblatex to typeset my bibliography and attempting to use the nature style. In the main text the citations appear correctly, and the bibliography entries are correctly formatted but the item number appears as 1. instead of [1]. How should I correct this?

I'm not sure if I haven't set the style correctly, or if another option somewhere is conflicting (I can't find one but I don't fully know where to look) or if there is a way to force it (again I've looked but can't figure it out).

The potentially relevant part of my preamble is:

\documentclass[12pt, a4paper, oneside]{matt}

\usepackage{amsmath}
\usepackage{amssymb}
\usepackage{amsfonts}
\usepackage{fancyhdr}
\usepackage{graphicx}
\usepackage{epstopdf}
\usepackage{gensymb}
\usepackage{siunitx}
\usepackage[table]{xcolor}
\usepackage{multirow}
\usepackage{bm}
\usepackage{wasysym}
\usepackage{acronym}

\usepackage[backend=bibtex,
                citestyle=nature,
                bibstyle=nature,
                sorting=none,
                firstinits=true,
                doi=false,isbn=false,url=false,eprint=false]{biblatex}

\usepackage[font=footnotesize, labelfont=bf, hang]{caption} 
\usepackage{subcaption}
\usepackage[export]{adjustbox}
\usepackage{tikz}
\usepackage{setspace}
\usepackage{hyperref}
\usepackage{cleveref}

Is this actually a style difference between bibtex and biblatex? I see here that for the biblatex nature style the format is 1. whilst here for the bibtex nature style the format is [1].

If so, how can I force my reference indices to appear as [1] instead of 1. in the bibliography?

Many thanks

  • Note for future reference that what you have shown us here is not an MWE. Is is not W as we can't run it when we copy and paste it into a .tex file (it is missing the \begin{document}...\end{document} bit ...); and it is not M as it contains quite some packages that don't have a bearing on the matter. – moewe Sep 30 '16 at 18:28
4

A simple

\DeclareFieldFormat{labelnumberwidth}{\mkbibbrackets{#1}}

is enough.

The MWE

\documentclass{article}
\usepackage[backend=bibtex,
            style=nature,
            sorting=none,
            giveninits=true,
            doi=false, isbn=false, url=false, eprint=false]{biblatex}
\addbibresource{biblatex-examples.bib}

\DeclareFieldFormat{labelnumberwidth}{\mkbibbrackets{#1}}

\begin{document}
  \cite{sigfridsson,cicero}
  \printbibliography
\end{document}

gives

example output

Note how we can replace citestyle=nature, bibstyle=nature, by the equivalent but shorter style=nature,. The option firstinits was renamed giveninits in version 3.3 of biblatex. You may also want to consider switching from BibTeX to Biber (backend=biber); BibTeX is now considered a legacy backend with limited support for the fancy features of biblatex.

  • Thank you very much (and sorry for the not-MW example, thanks for pointing that out). For future reference, where should I look for such options? I wouldn't know where to find out that its the labelnumberwidth field that needs to have a \mkbibbrackets format? Should I be able to find it in the biblatex manual? – Quantum_Oli Oct 1 '16 at 10:27
  • @Quantum_Oli This particular bit is not that easy to find in the manual (it is easier to find if you know the solution beforehand, but even then it's not too obvious - there is a description of labelnumberwidth, but I'm not sure if I would have known it was the right thing just from that). It might even have been easier to skim the code here (but then you need to know which bit of code is relevant). I largely learned from answers on this site and from examining code, the manual I mainly consult for technical questions. - Sorry for the unsatisfying answer. – moewe Oct 1 '16 at 10:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.