Following instructions from https://github.com/alecjacobson/coloremoji.sty ;

mkdir -p ~/Library/texmf/tex/latex/local
cd ~/Library/texmf/tex/latex/local
git clone git@github.com:alecjacobson/coloremoji.sty.git
texhash coloremoji.sty

Output the following;

$ texhash coloremoji.sty
texhash: Updating /home/vco/Library/texmf/tex/latex/local/coloremoji.sty/ls-R... 
texhash: Done.

However after trying to \usepackage{coloremoji} I got the following error;

! LaTeX Error: File `coloremoji.sty' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: sty)

I'm not sure why this is - it seems to be talking about not finding the file though. I tried to use this on ./coloremoji.sty/coloremoji.sty rather than just the dir, but this didn't work either. Returned the following message;

$ texhash ./coloremoji.sty/coloremoji.sty 
texhash: ./coloremoji.sty/coloremoji.sty: not a directory, skipping.
texhash: /usr/local/texlive/2015/texmf-config: directory not writable. Skipping...
texhash: /usr/local/texlive/2015/texmf-dist: directory not writable. Skipping...
texhash: /usr/local/texlive/2015/texmf-var: directory not writable. Skipping...
texhash: /usr/local/texlive/texmf-local: directory not writable. Skipping...
texhash: Done.

I'm not sure what I should do in order to get this working.


tried to run texhash with sudo

$ ls
vco @ geoHP
$ sudo texhash coloremoji.sty/
sudo: texhash: command not found
vco @ geoHP

Though it's on the system

$ which texhash

System that I'm using

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.5 LTS
Release:    14.04
Codename:   trusty
  • If I am not mistaken individual *.sty files are not texhash'd, rather you texhash and your system setup determines which directory texhash looks in. If you look in the questions there are a lot of questions regarding where to put the files, and how to deal with errors in texhashing. For instance in your example texhash is skipping directories because you are not root (or have insufficient privilege otherwise) and skipping "coloremoji.sty" because it is not a directory. – A Feldman Oct 1 '16 at 18:11
  • See this Question: tex.stackexchange.com/questions/21726/… try sudo texhash – A Feldman Oct 1 '16 at 18:18
  • And this one: tex.stackexchange.com/questions/1137/… – A Feldman Oct 1 '16 at 18:27
  • @AFeldman thanks - but in the first example there were no errors or mention of root, i'll try it now though with sudo thanks – baxx Oct 1 '16 at 18:39
  • linux or mac? I think if you specified your computing environment that would help. – A Feldman Oct 1 '16 at 20:20

You should not be using ~/Library/texmf if you are on Ubuntu. You should not have a directory ~/Library at all (unless you use it for your e-novels or something).

The relevant directory is probably ~/texmf. Check with

kpsewhich -var TEXMFHOME

Whichever directory is correct, texhash is almost certainly irrelevant unless you have altered the defaults. TeX doesn't use a database for your personal tree (TEXMFHOME) - it searches the file system directly. So when you install files there, that's enough. As long as the directory hierarchy is right, TeX will find the file. (And if it doesn't, texhash won't help.)

|improve this answer|||||
  • Finally, a canonical answer regarding 'texhash' and Ubuntu. Nice. – A Feldman Oct 2 '16 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.