5

I am trying to configure the MastersDoctoralThesis class in overleaf to accept greek character (My thesis has to be written in Greek).

What I did was to add the option greek when opening the document class. like that

\documentclass[greek,english,
11pt, % The default document font size, options: 10pt, 11pt, 12pt,
...,
]{MastersDoctoralThesis}

I also use the packages above

\usepackage[utf8]{inputenc} % Required for inputting international characters

\usepackage[T1]{fontenc} % Output font encoding for international characters

\usepackage{palatino} % Use the Palatino font by default

When I add some greek characters in the title I get

LaTeX Error: Command \textalpha unavailable in encoding T1.

Any idea how to fix that?

  • 1
    T1 is a latin encoding and has no Greek, but if you add \usepackage[greek]{babel} (which you will need anyway) it should add the LGR encoding which has Greek. – David Carlisle Oct 2 '16 at 19:41
  • If I add \usepackage[greek]{babel} before tha packges mentioned above I get LaTeX Error: Option clash for package babel – LetsPlayYahtzee Oct 2 '16 at 19:57
  • 1
    It's hard to debug fragments it is always best to make a small complete document that shows the error. – David Carlisle Oct 2 '16 at 20:21
  • Ι used \usepackage{textgreek} instead of \usepackage[greek]{babel} as a commented that was deleted suggested and this seems to have solved the problem – LetsPlayYahtzee Oct 2 '16 at 21:14
  • I did not see that your thesis is in Greek. Have you come across with tex.stackexchange.com/a/327234/4427 ? Of course palatino is not an option. – egreg Oct 2 '16 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.