1

I am on Max OSX, LyX 2.2.0, with tex4ht installed.

I have a master document with 4 child documents. Exporting any of the child documents individually as ODT works fine, but trying to export the whole thing from the master document gives me the error "No information for exporting the format OpenDocument (tex4ht)".

In fact, the menu option isn't there in the master, and I try to do it by selecting an output format in the "Export as..." dialog.

I haven't spotted anything obvious in the document settings for the master document that is different from the children, but I don't really know what to look for.

My question: is there a known problem with exporting a document containing child documents, or is there something I should check in either the preferences or document settings that may be causing the problem?

  • I haven't seen this problem. We would be interested in fixing it but we would need a minimal example (for example, do you need exactly 4 child documents to reproduce the problem?). Please read wiki.lyx.org/FAQ/MinimalExample and then post a minimal example along with your description at a new bug report at lyx.org/trac . By the way, how do you find the quality of ODT created? – scottkosty Oct 4 '16 at 14:06
  • I'm generally happy with the ODF, but it's only the PDF I care about for the final print run. This was just to get an editable copy of a manuscript out to someone who doesn't use LyX. – scav Oct 4 '16 at 14:35
  • ah good to know. So an "OK" export is good enough. – scottkosty Oct 4 '16 at 15:08
  • Update: I am now also seeing this behaviour with export PDF (pdflatext) on a different master document. Sorry I still haven't got around to making a minimal example, sorry. – scav Apr 23 '17 at 19:33
  • Difference seems to be "use non-Tex fonts" option is set in the master document. – scav Apr 23 '17 at 19:51
1

Never mind, this is a different problem than I originally thought.

I made a minimal example (empty child, master only containing the child document) and for both of them if "use non-TeX fonts" was selected in the document settings, the range of possible exports is greatly reduced.

The master/child relationship was irrelevant, so: problem not as described.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.