8

Is there any way to keep the URLs in the same form they are saved within the .bib files when using biblatex-chicago with Biber? For instance, the entry

@misc{RussianEmpire.1855,
 author = {Russian Empire},
 year = {1855},
 title = {Treaty of Shimoda},
 url = {https://ru.wikisource.org/wiki/Симодский_договор_с_Японией_(1855)},
}

results in the following output:

enter image description here

While there certain are benefits to converting the link itself, this sort of output in the footnote makes it both ugly and difficult to re-enter the link when reading a printed copy. How would one proceed about to receive the output along the lines of "https://ru.wikisource.org/wiki/Санкт-Петербургский_договор_с_Японией_(1875)"?

Minimal working example:

%!TEX program = xelatex
\documentclass{article}

\usepackage{fontspec}
\usepackage[russian,british]{babel}
\newfontfamily\russianfont[Script=Cyrillic]{CMU Serif} 
\usepackage[CJK, Cyrillics]{ucharclasses}
\setTransitionsForCyrillics{\russianfont}{}
\usepackage{csquotes}
\usepackage[labeldate,backend=biber]{biblatex-chicago}
\addbibresource{bibliography.bib}
\usepackage[unicode,hidelinks]{hyperref}

\begin{filecontents}{bibliography.bib}
@misc{RussianEmpire.1855,
 author = {Russian Empire},
 year = {1855},
 title = {Treaty of Shimoda},
 url = {https://ru.wikisource.org/wiki/Симодский_договор_с_Японией_(1855)},
}
\end{filecontents}

\begin{document}

Cyrillics support test: Тест\\

\cite{RussianEmpire.1855}

\end{document}

Output:

enter image description here

6
  • You should make a complete example. This would make tests much easier. Oct 4, 2016 at 16:21
  • Maybe when you copy and past, you (youre OS or whatever) change the encoding. Try a encoding-decoding software like asiteaboutnothing.net/c_decode-url.html
    – Amorok
    Oct 4, 2016 at 17:29
  • Added minimal working example illustrating the problem.
    – Arc
    Oct 4, 2016 at 18:04
  • 3
    biber URI encodes all URLS. Version 2.7, currently in development on Sourceforge, adds a new option --nouri-encode which disables URI encoding. This requires version 3.7 of biblatex, also in development.
    – PLK
    Oct 4, 2016 at 19:35
  • Thank you for the reply, PLK. Good to have it narrowed down. :)
    – Arc
    Oct 16, 2016 at 19:02

1 Answer 1

3

Biber 2.7 introduces a new option to disable URI encoding of URLs, use the switch

--nouri-encode

when you compile with Biber.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .