4

I try to compile my french report, but I get these two errors :

  • Package babel error : language definition file Frenchb.ldf not found \ProcessOptions*
  • Package babel error : you haven't specified a language option try to proceed from here, type x to quit}

Here is the latex code of babel.sty

\ProcessOptions*
\ifx\bbl@main@language\@undefined
  \PackageError{babel}{%
    You haven't specified a language option}{%
    You need to specify a language, either as a global
    option\MessageBreak
    or as an optional argument to the \string\usepackage\space
    command; \MessageBreak
    You shouldn't try to proceed from here, type x to quit.}
  \input{babel.def}
\fi 

I try to update texlive, but I get always the same problem

sudo apt-get install texlive-lang-all

Here the code.tex

\documentclass[a4paper,12pt,onehalfspacing,headrules,tools]{report}
\textheight 21.8cm \textwidth 15.cm \topmargin 0.cm \oddsidemargin
0.cm \evensidemargin 0.cm
\parindent=10pt
\itemsep=0pt
\parskip=0pt
\baselineskip=0pt
\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[Frenchb]{babel}
\usepackage{bm}
%\usepackage{graphicx}
\usepackage{color} 
\usepackage{amssymb}
\usepackage{amsmath}
\usepackage[pdftex]{graphicx}
%\usepackage[dvips]{graphicx}
%\usepackage[ruled,vlined,french,titlenumbered]{algorithm2e}
\usepackage{tabularx}
%\usepackage{algorithmic}
%\usepackage[boxed]{algorithm}
%\usepackage[]{algorithm}
\usepackage{fancyhdr}
\usepackage{longtable}
\usepackage[francais]{minitoc}
\begin{document}
\selectlanguage{french}
....

Any idea please?

Thank you

  • What input code produces this? – cfr Oct 4 '16 at 21:53
  • 1
    Off-topic: don't specify pdftex to graphicx. Better to use geometry and parskip. Setting \baselineskip to zero will look horrible so only do this if it is an institutional requirement. (Those always look horrible so it can't be helped.) Recommend using UTF8 encoding for your files, especially if writing French. None of these options seem to do anything: onehalfspacing,headrules,tools. Consider xcolor rather than color. You do not need \selectlanguage for the main language. Always post complete but minimal examples people can try to compile to reproduce the error. – cfr Oct 4 '16 at 22:02
5

Presumably you have

\documentclass[French]{<class>} 

or

\documentclass[Frenchb]{<class>} 

or

\usepackage[French]{babel}

or

\usepackage[Frenchb]{babel}

None of these are correct.

What you need is

\documentclass[frenchb]{<class>} 

or

\usepackage[frenchb]{babel}

or

\documentclass[french]{<class>} 

or

\usepackage[french]{babel}
  • I modify it to \usepackage[French]{babel} but the same problem – Poisson Oct 4 '16 at 22:00
  • @CyrineEzzahra I suggested that was the problem. OK. Actually the problem is Frenchb. But the solution is the same either way and I was guessing before you posted code. Use frenchb or french. Either will work just fine. – cfr Oct 4 '16 at 22:04
  • 1
    @CyrineEzzahra The problem isn't the b or not. The problem is the F. You want f with or without the b. – cfr Oct 4 '16 at 22:06
  • It's a problem with Windows that has a case insensitive file system, so asking for Frenchb.ldf is the same as asking for fReNCh.LdF. People take bad habits and, when switching to a real OS, they get into trouble. – egreg Oct 4 '16 at 22:22
  • 1
    @egreg I know what causes it. But OS X is worse - or used to be - since it is half case-sensitive and half case-insensitive. Yet I would count it as a real OS. Just a flawed one. (Well, they're all flawed. Even the non-real ones are flawed in non-real-OS ways.) – cfr Oct 4 '16 at 22:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.