0

In Mendeley, if I import the following RIS file:

TY  - JOUR
T1  - Title
A1  - First, Last
Y1  - 2000
JF  - Journal
L1  - file:///C://Paper.pdf

the pdf Paper.pdf will be imported into Mendeley. However, if I import the following BibTex file:

@article{Key
title   = {Title},
author  = {First, Last},
year    = {2000}
journal = {Journal},
file    = {///C://Paper.pdf},
}

Mendeley will import the correct title, author, year, and journal, but it will not import the file. Is there a special way the file field needs to formated to make this work? Thank you for the help.

closed as off-topic by user36296, Mensch, Martin Schröder, egreg, Zarko Oct 7 '16 at 21:40

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center." – user36296, Mensch, Martin Schröder, egreg, Zarko
If this question can be reworded to fit the rules in the help center, please edit the question.

  • What on earth does 'import' mean in this context? (Is it being used in two different ways? (i) importing into a .bib file and (ii) importing something into something/-where else?) A .bib file is just a means of organizing bibliographical information in a database; this database is primarily exploited by LaTeX such that you can \cite the information in a paper. To me, it looks like "import (i)" itself is flawed: no citation key after article{ and no space in the author field. I don't know how to represent DOS path names, really, so that might also be an issue. – jon Oct 5 '16 at 3:29
  • The space for the the author's name and key do not affect this problem, I've updated the example. What I mean by import is: in Mendeley Desktop, click File->Import->RIS, and when the RIS file above is imported into Mendeley, Mendeley will show that Paper.pdf is in the field "Files" and when you double click on the pdf, the pdf located at C://Paper.pdf will be opened. However, if you click File->Import->BibTex and import the BibTex file above, Paper.pdf will not be populated into the field "Files." Please let me know if this is still not clear. – user3904282 Oct 5 '16 at 3:46
  • The file field is nonstandard. It's certainly not recognized by most BibTeX bibliography style files. If you want Mendeley to recognize it, you'll probably need to provide some low-level programming assistance. Questions about Mendeley programming are probably off-topic for this site, though. – Mico Oct 5 '16 at 3:56
  • 2
    Yes, much clearer now. However, I have to agree that this sounds off-topic as it is about Mendeley, not about BibTeX. – jon Oct 5 '16 at 4:35
  • 1
    By the way, author = {First, Last}, is incorrect. It should be either author = {First Last}, or author = {Last, First},. If a comma is present, BibTeX will interpret the part before the commas as the surname, not the given name. – Mico Oct 5 '16 at 5:56
1

I'm a librarian who teaches both BibTeX and Mendeley. The .bib file import does only grab the references and not the file. It's intended as a citation-only import and not as a file import. The best way to import files is to go to the Mendeley preferences and set up the "auto-watch folders" option for whichever directory you put your research PDFs in. You can also set BibTeX options in the preferences for auto-generating output and doing awesome things like escaping special characters, which is something that not all reference management software will do.

If you want the appropriate metadata to come along with the pdf file because Mendeley has been parsing it incorrectly, use the DOI or arXiv ID lookup in the righthand panel for specific papers (look for the magnifying glasses). That should help.

Not the answer you're looking for? Browse other questions tagged or ask your own question.