2

I digged around and found no answer to the following problem: I defined the environment myroman but using I failed. It is not clear for me why. %

\documentclass{scrartcl}
   \usepackage{enumitem}
  \newenvironment{myroman}[1][label=\roman*)]%
        {\begin{enumerate}[#1]}
        {\end{enumerate}}
        %
\begin{document}

\begin{myroman}
    \item First
    \item Second
\end{myroman}  

\begin{myroman}[resume*] % not working
   \item Third
   \item etc
\end{myroman}
        %
This is working:
        %
 \begin{enumerate}[label=\roman*)]
     \item one
      \item two
 \end{enumerate}

 \begin{enumerate}[resume*] 
    \item three
     \item four
  end{enumerate}

\end{document}

  • Good question, but you have some typos/omissions in there that prevent compilation – Steven B. Segletes Oct 5 '16 at 14:46
  • enumitem package documentation, p. 6: the resume option acts locally; “if you want global resuming, see next section on series”. – GuM Oct 5 '16 at 14:47
  • Ups, this I missed. Now I understood it. – Ulrich Oct 5 '16 at 16:14
3

You should define a new list, for this.

\documentclass{scrartcl}
\usepackage{enumitem}

\newlist{myroman}{enumerate}{1}
\setlist[myroman,1]{label=\roman*)}

\begin{document}

\begin{myroman}
\item First

\item Second
\end{myroman}  

\begin{myroman}[resume*]
\item Third

\item etc
\end{myroman}

\end{document}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.