2

I am using a custom class (provided here) for my thesis. It is supposed to be based on the report class. It has two options a single and a double spacing option. I have to use doublespacing in the main text but I am allowed (and would like) to use singlespacing within the quote environment. The following works fine with report but not with my custom uclathes class.

% !TEX TS-program = xelatexmk
\documentclass{report} 
%\documentclass{uclathes} 
\usepackage[letterpaper,margin=1in,footskip=0.25in]{geometry}
\usepackage{setspace}
\doublespacing
\usepackage{lipsum}

\expandafter\def\expandafter\quote\expandafter{\quote\singlespacing}

\begin{document}
\lipsum[1]
\begin{quote}
\lipsum[1]
\end{quote}
\lipsum[1]
\end{document}

Now I bet that's because of the different options and some custom settings in the class. Would anyone be able to help me out where to look in the .cls file for what I might need to tweak to get this to work? I did find these lines

\def\quote{\list{}{\rightmargin\leftmargin}\item[]}
\let\endquote=\endlist

in the file which seem to be relevant. But how would I have to manipulate them (or something else) so that my \expandafter\def\expandafter\quote\expandafter{\quote\singlespacing} is respected?
Any hints much appreciated!

  • What happens if you comment out those lines in the class? An MWE would be useful. – cfr Nov 26 '16 at 14:04
  • 1
    Sure. I've just left the first one. – cfr Nov 27 '16 at 1:24
3

I ended up using the
\usepackage{setspace}% and
\usepackage{etoolbox}% packages and then simply saying:

 \AtBeginEnvironment{quote}{\singlespacing} 

That solved it without the need to modify anything in the class or class options files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.