1

I'm using tabu package to create a table. With the tabu package, I can specify the width of a table so that lengthy lines are wrapped into the column. However, it seems like that the lengthy line in multirow is not propery processed to fit into a column.

enter image description here

\documentclass[12pt, twocolumn]{article}
\usepackage{tabu}
\usepackage{booktabs}
\usepackage{multirow}

\begin{document}

\begin{tabu} to \linewidth{|X[c]|X[c]|X[c]|X[c]|}

\toprule
x & y & z & w \\
\tabucline{1-4}
\multirow{2}{*}{aaaaa aaaaaaa}  & b & c & d \\
& b & c & dddd sssss \\
\bottomrule

\end{tabu}  
\end{document}

How to make the lengthy line in a multi-row column to fit into the column widht?

  • if you have recent version of multirow packages just replace * with =. if not, than instead * write width of column. – Zarko Oct 5 '16 at 18:46
2

You need to use = instead of * in the multirow declaration:

\documentclass[12pt, twocolumn]{article}
\usepackage{tabu}
\usepackage{booktabs}
\usepackage{multirow}

\begin{document}

\begin{tabu} to \linewidth{|X[c]|X[c]|X[c]|X[c]|}

\toprule
x & y & z & w \\
\tabucline{1-4}
\multirow{2}{=}{aaaaa aaaaaaa}  & b & c & d \\
& b & c & dddd sssss \\
\bottomrule

\end{tabu}
\end{document}

enter image description here

  • I have an error with '=' option. – prosseek Oct 5 '16 at 18:51
  • Perhaps your multirow is too old. Check the documentation if it mentions =. – Ulrike Fischer Oct 5 '16 at 19:10
  • Upgrading to texlive 2016 and running tlmgr update multirow solved the error. – prosseek Oct 5 '16 at 19:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.