Fresh install of Mac OS Sierra, fresh install of MacTeX. If I run with the terminal pdflatex I get

-bash: pdflatex: command not found

Any idea?

Thank you for help and answers.

  • have you set the PATH variable?
    – naphaneal
    Commented Oct 6, 2016 at 15:34
  • Hello naphaneal, what do you exactly mean? Texshop:/Library/TeX/texbin, /usr/local/bin
    – Waldemar
    Commented Oct 6, 2016 at 15:36
  • maybe we try something first, before we meddle with the PATH. what does apropos pdflatex, whereis pdflatex and/or which pdflatex tell you?
    – naphaneal
    Commented Oct 6, 2016 at 15:44
  • sorry I can't follow your question. standard installation nothing changed. Before it was Yosemite and I install fresh Sierra. Has this something to do with Xcode. I'm already download it now.
    – Waldemar
    Commented Oct 6, 2016 at 15:49
  • these are commands you run in a Terminal. Xcode is only an IDE, in which you develop code. you don't need that in this case. I assume, that Mac OS Sierra is relatively new and so MacTeX and other software might not run properly because of changes in APIs and stuff in the OS.
    – naphaneal
    Commented Oct 6, 2016 at 16:01

2 Answers 2


According to post by Dick Koch on the macosx-tex mailing list:

This problem only concerns users who install Sierra on a new disk, rather than updating an existing system to Sierra.

If these users install MacTeX-2016 or BasicTeX-2016, they will discover that they cannot typeset from the command line. To fix this problem, download FixLink from my web site:


This is a very, very small download package; install the package.

Eventually this fix will be moved to BasicTeX-2016 and MacTeX-2016, but before remaking those packages, I want to make sure this one creates no problems. I certainly tested FixLink on my own machine.

The technical problem is that Sierra does not create the folders /etc/paths.d or /etc/manpaths.d, so our packages have to create them. XQuartz creates the folders as well, so another solution is to install XQuartz before installing BasicTeX or MacTeX.

Fix included in latest MacTeX download

The revised MacTeX download, dated 09 October 2016, includes the fix. See:


  • Sorry the link do not work.
    – Waldemar
    Commented Oct 6, 2016 at 17:01
  • I found the the fix and yes, the fix work ;-) Thank you all for the fast help and answers. All the best and have a great week, Waldemar
    – Waldemar
    Commented Oct 6, 2016 at 17:12
  • The fix is called FixLink.pkg and the URL is <pages.uoregon.edu/koch>; i.e., the .edu was missing in the answer above. Commented Oct 6, 2016 at 17:34
  • Great community!
    – Waldemar
    Commented Oct 6, 2016 at 18:05
  • 1
    FixLink.pkg wasn't included in MacTeX 2017. I got crazy after upgradation of MacTeX 2017 but your answer save my life[after installation this file, everything becomes normal as it was]!
    – Khaaba
    Commented Jun 13, 2017 at 0:45

It looks like the MacTeX package installed tools into the /Library/TeX/Distributions/Programs/texbin directory and adds a symlink to it at /usr/texbin, which made it onto my $PATH. After upgrading to Sierra, this symlink disappeared.

If you're using the command line, you can add the installed texbin directory to your path:

export PATH="$PATH:/Library/TeX/Distributions/Programs/texbin"

Sticking the above line in your ~/.bash_profile will cause that install directory to be in your path for your terminal windows.

  • Thanks this fixed it for me
    – ajivani
    Commented Nov 9, 2019 at 6:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .