1

I am aware there are many threads related to "l3kernel too old" but did not find them helpful.

I work in Ubuntu with TexLive 2016:

tex --version

TeX 3.14159265 (TeX Live 2016)

/usr/local/texlive/2016/bin/x86_64-linux is added to the PATH. It was installed as described in tug.org/texlive/quickinstall.html

Trying to update l3kernel by running

sudo tlmgr update l3kernel

I get the following information:

TeX Live 2015 is frozen forever and will no
longer be updated.  This happens in preparation for a new release.

You may want to try specifying an explicit or different CTAN mirror;
see the information and examples for the -repository option at
http://tug.org/texlive/doc/install-tl.html
(or in the output of install-tl --help).

TeX Live 2015 is frozen forever and will no
longer be updated.  This happens in preparation for a new release.

If you're interested in helping to pretest the new release (when
pretests are available), please read http://tug.org/texlive/pretest.html.
Otherwise, just wait, and the new release will be ready in due time.

Then:

  1. When trying to switch to another mirror I get checksum problems which I reported in tlmgr, changing repository, containerchecksum

  2. http://tug.org/texlive/pretest.html says

The pretest is over. See you next year.

  1. Is the only solution " just wait, and the new release will be ready in due time"? I need to compile the latex document before the new release is released.
  • 1
    Are you sure you are running tl16? Sounds more like tl15 (path error). Exactly which tl16 did you install? The Ubuntu one or did you manually install the upstream one? – daleif Oct 6 '16 at 20:23
  • what does which tlmgr report? – David Carlisle Oct 6 '16 at 20:38
  • which tlmgr /usr/local/texlive/2016/bin/x86_64-linux/tlmgr – Viesturs Oct 6 '16 at 20:40
  • and what repository? eg output from ` tlmgr info |head` – David Carlisle Oct 6 '16 at 20:44
  • 2
    bingo. you have a local copy of an old version in your path, just delete /home/v/texmf/tex/latex/l3kernel – David Carlisle Oct 6 '16 at 21:13
5

You have a local copy of an old version in your path, just delete

/home/v/texmf/tex/latex/l3kernel

which is the path returned by kpsewhich expl3.sty

  • 1
    +1, but this may not address a more general problem, which appears to be that sudo does not recognize his PATH settings and is still trying to update from TL2015.... – jon Oct 6 '16 at 21:34
  • @jon true (possibly there is a second tlmgr only available via sudo, or perhaps the description is misleading, hard to tell...) – David Carlisle Oct 7 '16 at 21:21
1

Download .zip file for l3kernal from http://mirrors.ctan.org/macros/latex/contrib/l3kernel.zip link.

Extract .zip file to get l3kernal file. Replace existing l3kernal file in location

C:\Program Files\MiKTeX 2.9\tex\latex

by extracted file. This is how I solve my problem of Support package l3kernel too old.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.