2

Sorry if this is a duplicate from other questions but I wasn't able to solve my problem referring to this article here and here.

I'm trying to configure FoxitReader 8.0 as default external viewer for TeXstudio (2.11.2) on Windows 10.

I tried Options --> Configure TeXstudio --> Commands --> External PDF Viewer --> C:\Program Files (x86)\Foxit Software\Foxit Reader\FoxitReader.exe

and

Options --> Configure TeXstudio --> Build --> [add user command] --> txs:///view-pdf-external

but I still get

Error: Could not start the command: C:\Program Files (x86)\Foxit Software\Foxit Reader\FoxitReader.exe

Any help would be much appreciated.

13
  • 1
    Welcome to TeX SX! Doesn't Foxit Reader lock .pdf files, just like Acrobat Reader? It's a huge problem when you compile the same code multiple times.
    – Bernard
    Commented Oct 7, 2016 at 17:20
  • Cannot answer, but suggest: Quotes around file "path/name"? Change backslashes to forward slashes? Perhaps instead use Foxit Reader Portable, in your home directory?
    – user103221
    Commented Oct 7, 2016 at 19:56
  • 1
    I'm not recommending Foxit as it does not support SyncTeX. Instead use SumatraPDF viewer
    – naphaneal
    Commented Oct 7, 2016 at 20:08
  • 1
    see if adding quotation marks to the path changes anything: "C:\Program Files (x86)\Foxit Software\Foxit Reader\FoxitReader.exe" %.pdf
    – naphaneal
    Commented Oct 8, 2016 at 11:51
  • 1
    @Bernard: You are right, but this behavior can be changed by calling Foxit as FoxitReader.exe <document> /A nolock=1 Commented Oct 8, 2016 at 12:39

1 Answer 1

7

Solution using @naphaneal's and @PhilippImhof's comments:

In

Options --> Configure TeXstudio --> Commands --> External PDF Viewer

change this

C:\Program Files (x86)\Foxit Software\Foxit Reader\FoxitReader.exe

to this

"C:\Program Files (x86)\Foxit Software\Foxit Reader\FoxitReader.exe" %.pdf

or this

"C:\Program Files (x86)\Foxit Software\Foxit Reader\FoxitReader.exe" %.pdf /A nolock=1

to avoid Foxit Reader to lock pdf files.

3
  • Small edit, %.pdf won't cut it. Instead use "?am.pdf" So, this works for me: "C:\Program Files (x86)\Foxit Software\Foxit Reader\FoxitReader.exe" "?am.pdf" /A nolock=1 Commented Mar 8, 2021 at 5:54
  • The exe file is now: FoxitPDFReader.exe Commented Aug 12, 2021 at 22:09
  • For the FoxitPDFEditor this works for me "C:/Program Files (x86)/Foxit Software/Foxit PDF Editor/FoxitPDFEditor.exe" "%.pdf" /A nolock=1 /.pdf
    – Al_Fh
    Commented Nov 26, 2023 at 9:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .