2

Good morning everyone!

I updated my OS to Sierra and TeXstudio seem not to work anymore. Everytime I try to compile something I get the message

Error: Could not start the command: /usr/texbin/pdflatex -synctex=1
-interaction=nonstopmode "document".tex

Thank you for your help!

I've changed the path but I'm still getting the same message. Can someone tell me if I changed the path in the rigth way?

I'm only using pdfLaTeX!

2
  • 1
    Have you checked the path? I remember when I upgraded my OS to El Captain, there is a problem with the path. See this tex.stackexchange.com/questions/270717/…
    – CroCo
    Commented Oct 9, 2016 at 15:12
  • 1
    You cannot have the installation under /usr/. This should not have worked with El Capitan either. There Apple decided to make a change in the security settings, called "Rootless", so only Apple signed application can change in /usr/ and some other directories. Hence, TeX moved from /usr/texbin/ to /Library/TeX/texbin/. For more about the change in El Capitan see e.g. apple.stackexchange.com/questions/193368.
    – StefanH
    Commented Oct 9, 2016 at 15:42

2 Answers 2

0

Check if perhaps you need:

/Library/TeX/Distributions/.DefaultTeX/Contents/Programs/texbin/pdflatex -synctex=1 -interaction=nonstopmode %.tex

That worked for me!

1
  • Great, you were right (sorry, I'm seeing the comment only now). Thank you very much!! Commented Dec 6, 2016 at 9:45
2

I have TS in Sierra and use PDFLaTeX. My path is

"/Library/TeX/texbin/pdflatex" -synctex=1 -interaction=nonstopmode %.tex

Note the quotes!!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .