3

This question already has an answer here:

I'm using \usepackage[style=verbose-ibid,backend=bibtex]{biblatex} to format my references with \footcite{} for the in text references, while also separating my chapters into individual tex files by using \include{ChapterName} in the main tex document.

However, I find that the footnotes seem to reset whever I start a new chapter; references in the first chapter are 1, 2, 3... but in the second chapter it also starts again from 1. I would like the numbering to be continuous, resuming from the last number in the previous chapter.

The other aspects I'm okay with, such as a shortened reference when referring to a reference that was referred to earlier in the document, and ibid when referring to the same reference again on the same page. Just the numbering should be continuous.

What would I need to add to the preamble for it to work like this?

Edit: My question was thought to be a duplicate of Bibliography per chapter with continuous numbering . Instead, my question is the opposite - I want numbering to be continuous throughout the whole report, with chapters resuming the numbering from the previous chapter.

Edit 2: Here's a MWE:

\documentclass{MastersDoctoralThesis}
\usepackage{style=verbose-ibid,backend=bibtex}[biblatex]
\addbibresource{Bibliography.bib}
\begin{document}
\mainmatter
\include{Chapter1}
\include{Chapter2}
\end{document}

The auxillary file contents are as follows:

Bibliography.bib:

@Article{gillies,
  author = {Gillies, Alexander},
  title = {Herder and the Preparation of Goethe's Idea of World Literature},
  journaltitle = {Publications of the English Goethe Society},
  volume = {9},
  date = {1933},
  pages = {46--67}}
@Article{bertram,
  author = {Bertram, Aaron and Wentworth, Richard},
  title = {Gromov invariants for holomorphic maps on Riemann surfaces},
  journaltitle = {J.~Amer. Math. Soc.},
  volume = {9},
  number = {2},
  date = {1996},
  pages = {529--571}}

Chapter1.tex:

Sample text\footcite{gillies}.

Chapter2.tex:

Some more\footcite{gillies} sample\footcite{bertram} text.

marked as duplicate by jon, Community Oct 13 '16 at 5:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I've tried addding the code under the % Overall entry counter, % Continued from this label number, % Skip entries with label numbers less than the continued number but that didn't seem to work. – Alisa Oct 12 '16 at 5:46
  • What about the options given to \usepackage{biblatex} ? – Jérôme Dequeker Oct 12 '16 at 7:01
  • Nope, doesn't make any difference - I need to use verbose-ibid formatting so I didn't change the style= part from verbose-ibid to numerical. – Alisa Oct 12 '16 at 10:07
  • can you give a MWE ? – Jérôme Dequeker Oct 12 '16 at 11:30
  • 1
    Does this work: \usepackage{chngcntr} \counterwithout{footnote}{chapter}? I don't have this document class and I try not to use these (implicitly?) CTAN-unfriendly classes.... – jon Oct 13 '16 at 1:43

Browse other questions tagged or ask your own question.