1

I'm totally new to all this.

Here is my BibTex source from Jabref

{@Article{Butt, author = {Butt, H.J. and Cappella, B. and Kappl, M.}, title = {Force measurements with the atomic force microscope: Technique, interpretation and applications}, journal = {Surface Science Reports}, year = {2005}, volume = {59}, number = {1–-6}, pages = {1 - 152}, doi = {http://dx.doi.org/10.1016/j.surfrep.2005.08.003}, issn = {0167-5729}, keywords = {Atomic force microscope, Force curves, Surface forces }, url = {http://www.sciencedirect.com/science/article/pii/S0167572905000488}, }

I copied this from a downloadable .bib file the hyphen shows correctly in the 'pages' part but not the volume part. (initially it was just (-) I changed it to (--) after looking around but it didn't really help, I also tried ( - ) like in the pages part.

This is how it outputs

H.J. Butt, B. Cappella, and M. Kappl. Force measurements with the atomic force microscope: Technique, interpretation and applications. Surface Science Reports, 59(1â-6):1 - 152, 2005.

(actually before adding the double hyphen I just got â so adding the double hyphen did get a hyphen to appear but didn't get rid of the â)

This is the LaTeX error description that shows in LyX:

...lock {\em Surface Science Reports}, 59(1†“-6):1 -- 152, 2005. You need to provide a definition with \DeclareInputText or \DeclareInputMath before using this key. Blockquote

I'm not sure where or how I would put these definitions so haven't tried.

The same thing is happening with this BibTex source too

{@Article{Gross, author = {Leo Gross}, title = {Recent advances in submolecular resolution with scanning probe microscopy}, journal = {Nature Chemistry}, year = {2011}, volume = {3}, pages = {273–-278}, } In the pages section.

Thanks.

If it matters I was using natbib but changed it to default, no help.

  • are you using bibtex or biber, something is generating utf8 but tex is apparently expecting latin1 so any multi-byte utf8 character is being garbled and coming out with nonsense starting with accented a (usual sign of mis-interpreted utf-8) – David Carlisle Oct 13 '16 at 18:23
1

You need to use two - if using the -- ligature,

For example your:

{273–-278},

is

  U+007b LEFT CURLY BRACKET     { { \lbrace
  U+0032 DIGIT TWO     2
  U+0037 DIGIT SEVEN     7
  U+0033 DIGIT THREE     3
  U+2013 EN DASH     – \textendash
  U+002d HYPHEN-MINUS     -
  U+0032 DIGIT TWO     2
  U+0037 DIGIT SEVEN     7
  U+0038 DIGIT EIGHT     8
  U+007d RIGHT CURLY BRACKET     } } \rbrace

Note the first dash is U+2013 not U+002D (–not-)

  • Wow. That is remarkable I didn't even notice the difference. How do I specify which dash I want I just hit the dash on my keyboard and have now fixed the issue using copy and paste. – J.B92 Oct 13 '16 at 18:36
  • @J.B92 no idea about your keyboard mapping, that's editor and operating system specific so not really tex related, also I wasn't clear how far back in the workflow the en-dash is in the file, in the input to jabref? or its output (I've never used jabref:-) – David Carlisle Oct 13 '16 at 18:42
  • Okay thanks. I'll just save a copy ready to be pasted. – J.B92 Oct 13 '16 at 19:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.